[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200327170534.GB24682@infradead.org>
Date: Fri, 27 Mar 2020 10:05:34 -0700
From: Christoph Hellwig <hch@...radead.org>
To: Eric Biggers <ebiggers@...nel.org>
Cc: Satya Tangirala <satyat@...gle.com>, linux-block@...r.kernel.org,
linux-scsi@...r.kernel.org, linux-fscrypt@...r.kernel.org,
linux-fsdevel@...r.kernel.org,
linux-f2fs-devel@...ts.sourceforge.net, linux-ext4@...r.kernel.org,
Barani Muthukumaran <bmuthuku@....qualcomm.com>,
Kuohong Wang <kuohong.wang@...iatek.com>,
Kim Boojin <boojin.kim@...sung.com>
Subject: Re: [PATCH v9 02/11] block: Inline encryption support for blk-mq
On Thu, Mar 26, 2020 at 01:05:11PM -0700, Eric Biggers wrote:
> > +{
> > + int i = 0;
> > + unsigned int inc = bytes >> bc->bc_key->data_unit_size_bits;
> > +
> > + while (i < BLK_CRYPTO_DUN_ARRAY_SIZE) {
> > + if (bc->bc_dun[i] + inc != next_dun[i])
> > + return false;
> > + /*
> > + * If addition of inc to the current entry caused an overflow,
> > + * then we have to carry "1" for the next entry - so inc
> > + * needs to be "1" for the next loop iteration). Otherwise,
> > + * we need inc to be 0 for the next loop iteration. Since
> > + * overflow can be determined by (bc->bc_dun[i] + inc) < inc
> > + * we can do the following.
> > + */
> > + inc = ((bc->bc_dun[i] + inc) < inc);
> > + i++;
> > + }
>
> This comment is verbose but doesn't really explain what's going on.
> I think it would be much more useful to add comments like:
Also the code is still weird. Odd double whitespaces, expression that
evaluate to bool.
>
> /*
> * If the addition in this limb overflowed, then the carry bit
> * into the next limb is 1. Else the carry bit is 0.
> */
> inc = ((bc->bc_dun[i] + inc) < inc);
if (bc->bc_dun[i] + carry < carry)
carry = 1;
else
carry = 0;
>
> > +blk_status_t __blk_crypto_init_request(struct request *rq,
> > + const struct blk_crypto_key *key)
> > +{
> > + return blk_ksm_get_slot_for_key(rq->q->ksm, key, &rq->crypt_keyslot);
> > +}
>
> The comment of this function seems outdated. All it does it get a keyslot, but
> the comment talks about initializing "crypto fields" (plural).
This is a classic case where I think the top of the function comment
is entirely useless. If there is a single caller in core code and the
function is completely trivial, there really is no point in a multi-line
comment. Comment should explain something unexpected or non-trivial,
while much of the comments in this series are just boilerplate making
the code harder to read.
> > blk_queue_bounce(q, &bio);
> > __blk_queue_split(q, &bio, &nr_segs);
> > @@ -2002,6 +2006,14 @@ static blk_qc_t blk_mq_make_request(struct request_queue *q, struct bio *bio)
> >
> > cookie = request_to_qc_t(data.hctx, rq);
> >
> > + ret = blk_crypto_init_request(rq, bio_crypt_key(bio));
> > + if (ret != BLK_STS_OK) {
> > + bio->bi_status = ret;
> > + bio_endio(bio);
> > + blk_mq_free_request(rq);
> > + return BLK_QC_T_NONE;
> > + }
> > +
> > blk_mq_bio_to_request(rq, bio, nr_segs);
>
> Wouldn't it make a lot more sense to do blk_crypto_init_request() after
> blk_mq_bio_to_request() rather than before?
>
> I.e., initialize request::crypt_ctx first, *then* get the keyslot. Not the
> other way around.
>
> That would allow removing the second argument to blk_crypto_init_request() and
> removing bio_crypt_key(). blk_crypto_init_request() would only need to take in
> the struct request.
And we can fail just the request on an error, so yes this doesn't
seem too bad.
Powered by blists - more mailing lists