lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 7 Oct 2020 11:12:40 -0700
From:   Ralph Campbell <>
To:     Jan Kara <>
CC:     <>, <>,
        <>, <>,
        <>, <>,
        Dan Williams <>,
        Matthew Wilcox <>,
        "Alexander Viro" <>,
        Theodore Ts'o <>,
        "Christoph Hellwig" <>,
        Andreas Dilger <>,
        "Darrick J. Wong" <>,
        Andrew Morton <>
Subject: Re: [PATCH] ext4/xfs: add page refcount helper

On 10/7/20 1:25 AM, Jan Kara wrote:
> On Tue 06-10-20 16:09:30, Ralph Campbell wrote:
>> There are several places where ZONE_DEVICE struct pages assume a reference
>> count == 1 means the page is idle and free. Instead of open coding this,
>> add a helper function to hide this detail.
>> Signed-off-by: Ralph Campbell <>
>> Reviewed-by: Christoph Hellwig <>
> Looks as sane direction but if we are going to abstract checks when
> ZONE_DEVICE page is idle, we should also update e.g.
> mm/swap.c:put_devmap_managed_page() or
> mm/gup.c:__unpin_devmap_managed_user_page() (there may be more places like
> this but I found at least these two...). Maybe Dan has more thoughts about
> this.
> 								Honza

I think this is a good point but I would like to make that a follow on
patch rather than add to this one.

Powered by blists - more mailing lists