lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:   Thu, 18 Feb 2021 06:51:31 +0000
From:   bugzilla-daemon@...zilla.kernel.org
To:     linux-ext4@...r.kernel.org
Subject: [Bug 211819] New: Processes stuck in D-state after accessing
 ext4+fast_commit+fscrypt

https://bugzilla.kernel.org/show_bug.cgi?id=211819

            Bug ID: 211819
           Summary: Processes stuck in D-state after accessing
                    ext4+fast_commit+fscrypt
           Product: File System
           Version: 2.5
    Kernel Version: 5.11.0 (5.10?)
          Hardware: All
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: ext4
          Assignee: fs_ext4@...nel-bugs.osdl.org
          Reporter: alxchk@...il.com
        Regression: No

I have several ext4, / and /home among them. /home fs do have user folder(s)
and mine is encrypted with fscrypt (v2 keying).

Recently I enabled fast_commit for all my ext4 fs with tune2fs -O fast_commit.
That time I used 5.10.x kernel. Once 5.11 was released, I tried it immediately.

Seconds after decrypting and using encrypted home folder, I was no longer able
to start new processes, which were not in FS cache -- all of them were in
D-state. I.e. encrypted folder was at /home/user at fs /home, executalbes are
in /bin/ at / fs. For example, if I run dmesg before decrypting and using
/home/user folder, it was (likely) cached, once I'm using /home/user folder
dmesg works, but other tools which were not previously used - doesn't. 

There were no any messages in dmesg, logs etc. I used SysRq to reboot the
system. Such situation happend every time. After reset FS had corruptions,
which were fixed by fsck. After several attempts I rollback to 5.10. It worked,
but hanged in same manner somewhere in 12 hours of usage. After that, I made
assumption, that this may be because of fast_commit (or my NVMe dying). I
checked smart status, it was fine. I disabled fast_commit just for /home fs,
rebooted to 5.11, and it works for 24h already (previously it hanged
immediately). So, maybe, this was because of fast_commit. 

Maybe it's worth to test this combination somehow..

-- 
You may reply to this email to add a comment.

You are receiving this mail because:
You are watching the assignee of the bug.

Powered by blists - more mailing lists