lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Tue, 12 Oct 2021 23:39:25 -0700 From: Kees Cook <keescook@...omium.org> To: Christoph Hellwig <hch@....de> Cc: Jens Axboe <axboe@...nel.dk>, Coly Li <colyli@...e.de>, Mike Snitzer <snitzer@...hat.com>, Song Liu <song@...nel.org>, David Sterba <dsterba@...e.com>, Josef Bacik <josef@...icpanda.com>, Theodore Ts'o <tytso@....edu>, OGAWA Hirofumi <hirofumi@...l.parknet.co.jp>, Dave Kleikamp <shaggy@...nel.org>, Ryusuke Konishi <konishi.ryusuke@...il.com>, Anton Altaparmakov <anton@...era.com>, Konstantin Komarov <almaz.alexandrovich@...agon-software.com>, Phillip Lougher <phillip@...ashfs.org.uk>, Jan Kara <jack@...e.com>, linux-block@...r.kernel.org, dm-devel@...hat.com, drbd-dev@...ts.linbit.com, linux-bcache@...r.kernel.org, linux-raid@...r.kernel.org, linux-mtd@...ts.infradead.org, linux-nvme@...ts.infradead.org, linux-scsi@...r.kernel.org, target-devel@...r.kernel.org, linux-fsdevel@...r.kernel.org, linux-btrfs@...r.kernel.org, linux-ext4@...r.kernel.org, jfs-discussion@...ts.sourceforge.net, linux-nfs@...r.kernel.org, linux-nilfs@...r.kernel.org, linux-ntfs-dev@...ts.sourceforge.net, ntfs3@...ts.linux.dev, reiserfs-devel@...r.kernel.org Subject: Re: don't use ->bd_inode to access the block device size On Wed, Oct 13, 2021 at 07:10:13AM +0200, Christoph Hellwig wrote: > I wondered about adding a helper for looking at the size in byte units > to avoid the SECTOR_SHIFT shifts in various places. But given that > I could not come up with a good name and block devices fundamentally > work in sector size granularity I decided against that. Without something like bdev_nr_bytes(), this series has 13 of 29 patches actually _adding_ an open-coded calculation: [PATCH 05/29] mtd/block2mtd: use bdev_nr_sectors instead of open coding it [PATCH 06/29] nvmet: use bdev_nr_sectors instead of open coding it [PATCH 07/29] target/iblock: use bdev_nr_sectors instead of open coding it [PATCH 08/29] fs: use bdev_nr_sectors instead of open coding it in blkdev_max_block [PATCH 11/29] btrfs: use bdev_nr_sectors instead of open coding it [PATCH 16/29] jfs: use bdev_nr_sectors instead of open coding it [PATCH 17/29] nfs/blocklayout: use bdev_nr_sectors instead of open coding it [PATCH 18/29] nilfs2: use bdev_nr_sectors instead of open coding it [PATCH 19/29] ntfs3: use bdev_nr_sectors instead of open coding it [PATCH 20/29] pstore/blk: use bdev_nr_sectors instead of open coding it [PATCH 21/29] reiserfs: use bdev_nr_sectors instead of open coding it [PATCH 22/29] squashfs: use bdev_nr_sectors instead of open coding it [PATCH 23/29] block: use bdev_nr_sectors instead of open coding it in blkdev_fallocate I think it's well worth having that helper (or at least leaving these alone). Otherwise, this is a lot of churn without a clear net benefit, IMO. The others look good to me, though! -Kees > > Diffstat: > block/fops.c | 2 +- > drivers/block/drbd/drbd_int.h | 3 +-- > drivers/md/bcache/super.c | 2 +- > drivers/md/bcache/util.h | 4 ---- > drivers/md/bcache/writeback.c | 2 +- > drivers/md/dm-bufio.c | 2 +- > drivers/md/dm-cache-metadata.c | 2 +- > drivers/md/dm-cache-target.c | 2 +- > drivers/md/dm-clone-target.c | 2 +- > drivers/md/dm-dust.c | 5 ++--- > drivers/md/dm-ebs-target.c | 2 +- > drivers/md/dm-era-target.c | 2 +- > drivers/md/dm-exception-store.h | 2 +- > drivers/md/dm-flakey.c | 3 +-- > drivers/md/dm-integrity.c | 6 +++--- > drivers/md/dm-linear.c | 3 +-- > drivers/md/dm-log-writes.c | 4 ++-- > drivers/md/dm-log.c | 2 +- > drivers/md/dm-mpath.c | 2 +- > drivers/md/dm-raid.c | 6 +++--- > drivers/md/dm-switch.c | 2 +- > drivers/md/dm-table.c | 3 +-- > drivers/md/dm-thin-metadata.c | 2 +- > drivers/md/dm-thin.c | 2 +- > drivers/md/dm-verity-target.c | 3 +-- > drivers/md/dm-writecache.c | 2 +- > drivers/md/dm-zoned-target.c | 2 +- > drivers/md/md.c | 26 +++++++++++--------------- > drivers/mtd/devices/block2mtd.c | 5 +++-- > drivers/nvme/target/io-cmd-bdev.c | 4 ++-- > drivers/target/target_core_iblock.c | 5 +++-- > fs/affs/super.c | 2 +- > fs/btrfs/dev-replace.c | 2 +- > fs/btrfs/disk-io.c | 3 ++- > fs/btrfs/ioctl.c | 4 ++-- > fs/btrfs/volumes.c | 7 ++++--- > fs/buffer.c | 4 ++-- > fs/cramfs/inode.c | 2 +- > fs/ext4/super.c | 2 +- > fs/fat/inode.c | 5 +---- > fs/hfs/mdb.c | 2 +- > fs/hfsplus/wrapper.c | 2 +- > fs/jfs/resize.c | 5 ++--- > fs/jfs/super.c | 5 ++--- > fs/nfs/blocklayout/dev.c | 4 ++-- > fs/nilfs2/ioctl.c | 2 +- > fs/nilfs2/super.c | 2 +- > fs/nilfs2/the_nilfs.c | 3 ++- > fs/ntfs/super.c | 8 +++----- > fs/ntfs3/super.c | 3 +-- > fs/pstore/blk.c | 4 ++-- > fs/reiserfs/super.c | 7 ++----- > fs/squashfs/super.c | 5 +++-- > fs/udf/lowlevel.c | 5 ++--- > fs/udf/super.c | 9 +++------ > include/linux/genhd.h | 6 ++++++ > 56 files changed, 100 insertions(+), 117 deletions(-) -- Kees Cook
Powered by blists - more mailing lists