lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 14 Oct 2021 08:28:44 +0200
From:   Christoph Hellwig <>
To:     Jens Axboe <>
Cc:     Coly Li <>, Mike Snitzer <>,
        Song Liu <>, David Sterba <>,
        Josef Bacik <>,
        Theodore Ts'o <>,
        OGAWA Hirofumi <>,
        Dave Kleikamp <>,
        Ryusuke Konishi <>,
        Anton Altaparmakov <>,
        Konstantin Komarov <>,
        Kees Cook <>,
        Phillip Lougher <>,
        Jan Kara <>,,,,,,,,,,,,,,,,,,
Subject: Re: don't use ->bd_inode to access the block device size

On Wed, Oct 13, 2021 at 07:10:13AM +0200, Christoph Hellwig wrote:
> I wondered about adding a helper for looking at the size in byte units
> to avoid the SECTOR_SHIFT shifts in various places.  But given that
> I could not come up with a good name and block devices fundamentally
> work in sector size granularity I decided against that.

So it seems like the biggest review feedback is that we should have
such a helper.  I think the bdev_size name is the worst as size does
not imply a particular unit.  bdev_nr_bytes is a little better but I'm
not too happy.  Any other suggestions or strong opinions?

Powered by blists - more mailing lists