[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7C4AC4BD-B62D-41B3-AAF7-46125D1A1146@tuxera.com>
Date: Fri, 15 Oct 2021 14:37:41 +0000
From: Anton Altaparmakov <anton@...era.com>
To: Christoph Hellwig <hch@....de>
CC: Jens Axboe <axboe@...nel.dk>, Coly Li <colyli@...e.de>,
Mike Snitzer <snitzer@...hat.com>, Song Liu <song@...nel.org>,
David Sterba <dsterba@...e.com>,
Josef Bacik <josef@...icpanda.com>,
Theodore Ts'o <tytso@....edu>,
OGAWA Hirofumi <hirofumi@...l.parknet.co.jp>,
Dave Kleikamp <shaggy@...nel.org>,
Ryusuke Konishi <konishi.ryusuke@...il.com>,
"Konstantin Komarov" <almaz.alexandrovich@...agon-software.com>,
Kees Cook <keescook@...omium.org>,
Phillip Lougher <phillip@...ashfs.org.uk>,
Jan Kara <jack@...e.com>,
"linux-block@...r.kernel.org" <linux-block@...r.kernel.org>,
"dm-devel@...hat.com" <dm-devel@...hat.com>,
"drbd-dev@...ts.linbit.com" <drbd-dev@...ts.linbit.com>,
"linux-bcache@...r.kernel.org" <linux-bcache@...r.kernel.org>,
"linux-raid@...r.kernel.org" <linux-raid@...r.kernel.org>,
"linux-nvme@...ts.infradead.org" <linux-nvme@...ts.infradead.org>,
"linux-scsi@...r.kernel.org" <linux-scsi@...r.kernel.org>,
"target-devel@...r.kernel.org" <target-devel@...r.kernel.org>,
"linux-fsdevel@...r.kernel.org" <linux-fsdevel@...r.kernel.org>,
"linux-btrfs@...r.kernel.org" <linux-btrfs@...r.kernel.org>,
"linux-ext4@...r.kernel.org" <linux-ext4@...r.kernel.org>,
"jfs-discussion@...ts.sourceforge.net"
<jfs-discussion@...ts.sourceforge.net>,
"linux-nfs@...r.kernel.org" <linux-nfs@...r.kernel.org>,
"linux-nilfs@...r.kernel.org" <linux-nilfs@...r.kernel.org>,
"linux-ntfs-dev@...ts.sourceforge.net"
<linux-ntfs-dev@...ts.sourceforge.net>,
"ntfs3@...ts.linux.dev" <ntfs3@...ts.linux.dev>,
"reiserfs-devel@...r.kernel.org" <reiserfs-devel@...r.kernel.org>
Subject: Re: [PATCH 02/30] block: add a bdev_nr_bytes helper
Hi Christoph,
> On 15 Oct 2021, at 14:26, Christoph Hellwig <hch@....de> wrote:
>
> Add a helpe to query the size of a block device in bytes. This
> will be used to remove open coded access to ->bd_inode.
Matthew already pointed out the return type for bdev_nr_bytes() but also your commit message has a typo: "Add a helpe" -> "Add a helper".
Best regards,
Anton
> Signed-off-by: Christoph Hellwig <hch@....de>
> ---
> include/linux/genhd.h | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/include/linux/genhd.h b/include/linux/genhd.h
> index 082a3e5fd8fa1..f67db3c5a04b3 100644
> --- a/include/linux/genhd.h
> +++ b/include/linux/genhd.h
> @@ -235,9 +235,14 @@ static inline sector_t get_start_sect(struct block_device *bdev)
> return bdev->bd_start_sect;
> }
>
> +static inline sector_t bdev_nr_bytes(struct block_device *bdev)
> +{
> + return i_size_read(bdev->bd_inode);
> +}
> +
> static inline sector_t bdev_nr_sectors(struct block_device *bdev)
> {
> - return i_size_read(bdev->bd_inode) >> 9;
> + return bdev_nr_bytes(bdev) >> SECTOR_SHIFT;
> }
>
> static inline sector_t get_capacity(struct gendisk *disk)
> --
> 2.30.2
>
Powered by blists - more mailing lists