lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 15 Oct 2021 09:58:06 -0700
From:   Kees Cook <>
To:     Christoph Hellwig <>
Cc:     Jens Axboe <>, Coly Li <>,
        Mike Snitzer <>, Song Liu <>,
        David Sterba <>,
        Josef Bacik <>,
        Theodore Ts'o <>,
        OGAWA Hirofumi <>,
        Dave Kleikamp <>,
        Ryusuke Konishi <>,
        Anton Altaparmakov <>,
        Konstantin Komarov <>,
        Phillip Lougher <>,
        Jan Kara <>,,,,,,,,,,,,,,,,,
Subject: Re: [PATCH 25/30] block: add a sb_bdev_nr_blocks helper

On Fri, Oct 15, 2021 at 03:26:38PM +0200, Christoph Hellwig wrote:
> Add a helper to return the size of sb->s_bdev in sb->s_blocksize_bits
> based unites.  Note that SECTOR_SHIFT has to be open coded due to
> include dependency issues for now, but I have a plan to sort that out
> eventually.
> Signed-off-by: Christoph Hellwig <>

You can adjust this changelog to remove the note about SECTOR_SHIFT
now. :)

Reviewed-by: Kees Cook <>

Kees Cook

Powered by blists - more mailing lists