lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 27 Jan 2022 17:50:39 +0530
From:   Ritesh Harjani <>
To:     Maxim Blinov <>
        linux-fsdevel <>
Subject: Re: Help! How to delete an 8094-byte PATH?

cc'ing linux-fsdevel too.

On 22/01/27 07:06AM, Maxim Blinov wrote:
> Hi all,
> I'm not a subscriber to this list (so please put me in the CC), but I've
> hit a really annoying un-googleable issue that I don't know who to ask
> about.
> A runaway script has been recursively creating sub-directories under
> sub-directories until it hit the (apparent) OS limit. The path in
> question goes something like this:
> /work/build-native/binutils-gdb/gnulib/confdir3/confdir3/confdir3/confdir3/confdir3/........
> (you get the idea)
> It was only stopped by the following error:
> mkdir: cannot create directory 'confdir3': File name too long
> OK, fine, that was silly but whatever, right? I tried to delete this
> huge directory from the top with


> rm -rf confdir3/
> but that simply generated the same error as above. So, I figured "Hey,

Strange. Though I didn't try creating same name subdirectories like how you have
done above i.e. confdir3 within confdir3 and recurse.
But I was able to remove the parent directory after hitting the max PATH_LEN

I ran this test below test to see if it fails on my ext4 latest tree. But this

But just curious, by any chance did below fixes it for you?
echo 3 > /proc/sys/vm/drop_caches


> I'll just walk all the way to the bottom, and delete the directories
> one-by-one bottom up". Here's the script I ran to get to the bottom:
> $ for i in $(seq 999999); do echo "im $i levels deep"; cd confdir3; done;
> It then ran for a while, and eventually I got to the bottom:
> ```
> ...
> im 892 levels deep
> im 893 levels deep
> im 894 levels deep
> im 895 levels deep
> im 896 levels deep
> bash: cd: confdir3: File name too long
> $ ls
> <nothing here>
> ```
> So then, I `cd ../`, and `rmdir confdir3`, but even here, I get
> rmdir: failed to remove 'confdir3/': File name too long
> I would be very grateful if someone could please help suggest how I
> might get this infernal tower of directories off of my precious ext4
> partition.
> I was thinking maybe there's some kind of magic "forget this directory
> inode ever existed" command, but I am out of my depth with filesystems.
> Best Regards,
> Maxim Blinov

Powered by blists - more mailing lists