[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20220204101008.xjqxsqmxzqtzrztj@riteshh-domain>
Date: Fri, 4 Feb 2022 15:40:08 +0530
From: Ritesh Harjani <riteshh@...ux.ibm.com>
To: Jan Kara <jack@...e.cz>
Cc: linux-ext4@...r.kernel.org, linux-fsdevel@...r.kernel.org,
"Theodore Ts'o" <tytso@....edu>,
Harshad Shirwadkar <harshadshirwadkar@...il.com>
Subject: Re: [RFC 4/6] ext4: No need to test for block bitmap bits in
ext4_mb_mark_bb()
On 22/02/01 12:38PM, Jan Kara wrote:
> On Mon 31-01-22 20:46:53, Ritesh Harjani wrote:
> > We don't need the return value of mb_test_and_clear_bits() in ext4_mb_mark_bb()
> > So simply use mb_clear_bits() instead.
> >
> > Signed-off-by: Ritesh Harjani <riteshh@...ux.ibm.com>
>
> Looks good. I'm rather confused by ext4_set_bits() vs mb_clear_bits()
> asymetry but that's not directly related to this patch. Just another
> cleanup to do. Feel free to add:
Yes, make sense. Looking at ext4_set_bits(), I think it should be renamed to
mb_set_bits() for uniform API conventions.
>
> Reviewed-by: Jan Kara <jack@...e.cz>
>
Thanks :)
> Honza
>
> > ---
> > fs/ext4/mballoc.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/fs/ext4/mballoc.c b/fs/ext4/mballoc.c
> > index 60d32d3d8dc4..2f931575e6c2 100644
> > --- a/fs/ext4/mballoc.c
> > +++ b/fs/ext4/mballoc.c
> > @@ -3943,7 +3943,7 @@ void ext4_mb_mark_bb(struct super_block *sb, ext4_fsblk_t block,
> > if (state)
> > ext4_set_bits(bitmap_bh->b_data, blkoff, clen);
> > else
> > - mb_test_and_clear_bits(bitmap_bh->b_data, blkoff, clen);
> > + mb_clear_bits(bitmap_bh->b_data, blkoff, clen);
> > if (ext4_has_group_desc_csum(sb) &&
> > (gdp->bg_flags & cpu_to_le16(EXT4_BG_BLOCK_UNINIT))) {
> > gdp->bg_flags &= cpu_to_le16(~EXT4_BG_BLOCK_UNINIT);
> > --
> > 2.31.1
> >
> --
> Jan Kara <jack@...e.com>
> SUSE Labs, CR
Powered by blists - more mailing lists