[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230108194034.1444764-1-agruenba@redhat.com>
Date: Sun, 8 Jan 2023 20:40:24 +0100
From: Andreas Gruenbacher <agruenba@...hat.com>
To: Christoph Hellwig <hch@...radead.org>,
"Darrick J . Wong" <djwong@...nel.org>,
Alexander Viro <viro@...iv.linux.org.uk>,
Matthew Wilcox <willy@...radead.org>
Cc: Andreas Gruenbacher <agruenba@...hat.com>,
linux-xfs@...r.kernel.org, linux-fsdevel@...r.kernel.org,
linux-ext4@...r.kernel.org, cluster-devel@...hat.com
Subject: [RFC v6 00/10] Turn iomap_page_ops into iomap_folio_ops
Here's an updated version of this patch queue. Changes since v5 [*]:
* A new iomap-internal __iomap_get_folio() helper was added.
* The previous iomap-internal iomap_put_folio() helper was renamed to
__iomap_put_folio() to mirror __iomap_get_folio().
* The comment describing struct iomap_folio_ops was still referring to
pages instead of folios in two places.
Is this good enough for iomap-for-next now, please?
Thanks,
Andreas
[*] https://lore.kernel.org/linux-xfs/20221231150919.659533-1-agruenba@redhat.com/
Andreas Gruenbacher (10):
iomap: Add __iomap_put_folio helper
iomap/gfs2: Unlock and put folio in page_done handler
iomap: Rename page_done handler to put_folio
iomap: Add iomap_get_folio helper
iomap/gfs2: Get page in page_prepare handler
iomap: Add __iomap_get_folio helper
iomap: Rename page_prepare handler to get_folio
iomap/xfs: Eliminate the iomap_valid handler
iomap: Rename page_ops to folio_ops
xfs: Make xfs_iomap_folio_ops static
fs/gfs2/bmap.c | 38 ++++++++++-----
fs/iomap/buffered-io.c | 105 +++++++++++++++++++++++------------------
fs/xfs/xfs_iomap.c | 41 +++++++++++-----
include/linux/iomap.h | 50 +++++++++-----------
4 files changed, 134 insertions(+), 100 deletions(-)
--
2.38.1
Powered by blists - more mailing lists