[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230323140517.1070239-1-yanaijie@huawei.com>
Date: Thu, 23 Mar 2023 22:05:09 +0800
From: Jason Yan <yanaijie@...wei.com>
To: <tytso@....edu>, <adilger.kernel@...ger.ca>, <jack@...e.cz>,
<ritesh.list@...il.com>, <lczerner@...hat.com>,
<linux-ext4@...r.kernel.org>
CC: Jason Yan <yanaijie@...wei.com>
Subject: [PATCH 0/8] some refactor of __ext4_fill_super(), part 2.
This is a continuous effort to make __ext4_fill_super() shorter and more
readable. The previous work is here[1]. I'm using my spare time to do this
work so it's a bit late after the previous series.
[1] http://patchwork.ozlabs.org/project/linux-ext4/cover/20220916141527.1012715-1-yanaijie@huawei.com/
Jason Yan (8):
ext4: factor out ext4_hash_info_init()
ext4: factor out ext4_percpu_param_init() and
ext4_percpu_param_destroy()
ext4: use ext4_group_desc_free() in ext4_put_super() to save some
duplicated code
ext4: factor out ext4_flex_groups_free()
ext4: rename two functions with 'check'
ext4: move s_reserved_gdt_blocks and addressable checking into
ext4_check_geometry()
ext4: factor out ext4_block_group_meta_init()
ext4: move dax and encrypt checking into
ext4_check_feature_compatibility()
fs/ext4/super.c | 392 ++++++++++++++++++++++++++----------------------
1 file changed, 209 insertions(+), 183 deletions(-)
--
2.31.1
Powered by blists - more mailing lists