[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20231012172835.GD255452@mit.edu>
Date: Thu, 12 Oct 2023 13:28:35 -0400
From: "Theodore Ts'o" <tytso@....edu>
To: "Ritesh Harjani (IBM)" <ritesh.list@...il.com>
Cc: linux-ext4@...r.kernel.org, Ojaswin Mujoo <ojaswin@...ux.ibm.com>
Subject: Re: [PATCH 1/2] kvm-xfstests: install-kconfig: Use $ARCH-config
instead of $KERN_ARCH-config
On Wed, Oct 11, 2023 at 12:46:30AM +0530, Ritesh Harjani (IBM) wrote:
> $KERN_ARCH is used for make arguments. For configs let's use
> $ARCH-config. This should not break anything since as of now we only
> have arm64-config for which $ARCH and $KERN_ARCH is same.
>
> Signed-off-by: Ritesh Harjani (IBM) <ritesh.list@...il.com>
It would be much better to teach set_canoncalized_arch about the
powerpc64le architecture. That way other scripts that use
set_canoicalized_arch can correctly depend on KERN_ARCH. See
run-fstests/util/arch_funcs:
# There are multiple ways that CPU architectured can be named.
# KERN_ARCH is what is used when specifying ARCH=xxx when building the
# kernel.
#
# GCE_ARCH is what gets used when setting specifying the architecture
# when creating the GCE image using the --architecture flag
# ARCH (after being canonicalized by this function) is defined by
# the Debian architecture port names[1] and is used internally
# by gce-xfstests and kvm-xfstests. So for example, when we add
# support for support for Power architectures, the ARCH name that should
# be used is ppc64 or ppc64el.
...
# This function takes as input a user-supplied architecture (which
# generally should be a Debian port name, but users might use
# a $(uname -m) instead.
#
function set_canonicalized_arch () {
case "$1" in
arm64|aarch64)
ARCH="arm64"
GCE_ARCH="ARM64"
KERN_ARCH="arm64"
;;
...
So basically, after calling set_canoncalized_arch, ARCH should be
Debian architecture port name, GCE_ARCH (if not the empty string) is
the name of the GCE architecture name, and KERN_ARCH should be what
should be passed to the Kernel makefile as "make ARCH=$KERN_ARCH ..."
- Ted
Powered by blists - more mailing lists