lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 18 Oct 2023 15:19:02 +0100
From:   Matthew Wilcox <>
To:     Ryusuke Konishi <>
Cc:     Andrew Morton <>,,,,,,,,,
        Pankaj Raghav <>
Subject: Re: [PATCH v2 01/27] buffer: Return bool from grow_dev_folio()

On Wed, Oct 18, 2023 at 04:41:44AM +0900, Ryusuke Konishi wrote:
> On Tue, Oct 17, 2023 at 5:11 AM Matthew Wilcox (Oracle) wrote:
> >
> > Rename grow_dev_page() to grow_dev_folio() and make it return a bool.
> > Document what that bool means; it's more subtle than it first appears.
> > Also rename the 'failed' label to 'unlock' beacuse it's not exactly
> > 'failed'.  It just hasn't succeeded.
> This changes the return type of grow_buffers() from "int"  to "bool".
> But, it seems that the caller, __getblk_slow(), has not changed the
> type of the variable "ret" that receives its return value:
> So, it looks like the error check immediately after calling
> grow_buffers() will not branch like before.
> Is this okay ?   Or, am I missing some other changes?
> Also, there is a typo in the changelog: "beacuse" -> "because".

Argh, yes.  Andrew, please drop this patch for now.  I'll submit
something better next cycle.

Powered by blists - more mailing lists