[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c2fdb9bb-e360-4ece-930d-bab4354f1abf@oracle.com>
Date: Mon, 10 Mar 2025 10:54:23 +0000
From: John Garry <john.g.garry@...cle.com>
To: Carlos Maiolino <cem@...nel.org>
Cc: brauner@...nel.org, djwong@...nel.org, linux-xfs@...r.kernel.org,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
ojaswin@...ux.ibm.com, ritesh.list@...il.com,
martin.petersen@...cle.com, tytso@....edu, linux-ext4@...r.kernel.org
Subject: Re: [PATCH v4 11/12] xfs: Update atomic write max size
On 10/03/2025 10:06, Carlos Maiolino wrote:
>> diff --git a/fs/xfs/xfs_mount.h b/fs/xfs/xfs_mount.h
>> index fbed172d6770..bc96b8214173 100644
>> --- a/fs/xfs/xfs_mount.h
>> +++ b/fs/xfs/xfs_mount.h
>> @@ -198,6 +198,7 @@ typedef struct xfs_mount {
>> bool m_fail_unmount;
>> bool m_finobt_nores; /* no per-AG finobt resv. */
>> bool m_update_sb; /* sb needs update in mount */
>> + xfs_extlen_t awu_max; /* data device max atomic write */
> Could you please rename this to something else? All fields within xfs_mount
> follows the same pattern m_<name>. Perhaps m_awu_max?
Fine, but I think I then need to deal with spilling multiple lines to
accommodate a proper comment.
>
> I was going to send a patch replacing it once I had this merged, but giving
> Dave's new comments, and the conflicts with zoned devices, you'll need to send a
> V5, so, please include this change if nobody else has any objections on keeping
> the xfs_mount naming convention.
What branch do you want me to send this against?
Thanks,
John
Powered by blists - more mailing lists