lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 13 Jan 2021 09:59:59 -0800
From:   Kees Cook <keescook@...omium.org>
To:     Josh Poimboeuf <jpoimboe@...hat.com>
Cc:     Valdis Klētnieks <valdis.kletnieks@...edu>,
        Geert Uytterhoeven <geert@...ux-m68k.org>,
        linux-hardening@...r.kernel.org,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v2] gcc-plugins: fix gcc 11 indigestion with plugins...

On Wed, Jan 13, 2021 at 11:08:36AM -0600, Josh Poimboeuf wrote:
> On Tue, Jan 12, 2021 at 08:19:16PM -0500, Valdis Klētnieks wrote:
> > Fedora Rawhide has started including gcc 11,and the g++ compiler
> > throws a wobbly when it hits scripts/gcc-plugins:
> > 
> >   HOSTCXX scripts/gcc-plugins/latent_entropy_plugin.so
> > In file included from /usr/include/c++/11/type_traits:35,
> >                  from /usr/lib/gcc/x86_64-redhat-linux/11/plugin/include/system.h:244,
> >                  from /usr/lib/gcc/x86_64-redhat-linux/11/plugin/include/gcc-plugin.h:28,
> >                  from scripts/gcc-plugins/gcc-common.h:7,
> >                  from scripts/gcc-plugins/latent_entropy_plugin.c:78:
> > /usr/include/c++/11/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO
> >  C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
> >    32 | #error This file requires compiler and library support \
> > 
> > Patch is more complicated than would otherwise be needed, because
> > older gcc (4.9, 5.4) have gnu++11 but throw an error due to a gcc bug
> > https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69959
> > 
> > Signed-off-by: Valdis Kletnieks <valdis.kletnieks@...edu>
> > ---
> > diff --git a/scripts/gcc-plugins/Makefile b/scripts/gcc-plugins/Makefile
> > index d66949bfeba4..cc779973724a 100644
> > --- a/scripts/gcc-plugins/Makefile
> > +++ b/scripts/gcc-plugins/Makefile
> > @@ -21,10 +21,13 @@ always-y += $(GCC_PLUGIN)
> >  
> >  GCC_PLUGINS_DIR = $(shell $(CC) -print-file-name=plugin)
> >  
> > +# need gnu++11 for gcc 11, but 4.9 and 5.4 need gnu++98
> > +GCC_FLAVOR = $(call cc-ifversion, -ge, 1100, 11, 98)
> > +
> >  plugin_cxxflags	= -Wp,-MMD,$(depfile) $(KBUILD_HOSTCXXFLAGS) -fPIC \
> > -		   -I $(GCC_PLUGINS_DIR)/include -I $(obj) -std=gnu++98 \
> > +		   -I $(GCC_PLUGINS_DIR)/include -I $(obj) -std=gnu++$(GCC_FLAVOR) \
> >  		   -fno-rtti -fno-exceptions -fasynchronous-unwind-tables \
> > -		   -ggdb -Wno-narrowing -Wno-unused-variable -Wno-c++11-compat \
> > +		   -ggdb -Wno-narrowing -Wno-unused-variable \
> >  		   -Wno-format-diag
> >  
> >  plugin_ldflags	= -shared
> 
> The first patch has already been merged into Linus' tree, so this
> probably should be an incremental fix on top, with a Fixes: tag.

Yes, please. :)

-- 
Kees Cook

Powered by blists - more mailing lists