lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 20 Aug 2021 19:25:50 +0100
From:   Matthew Wilcox <willy@...radead.org>
To:     Joe Perches <joe@...ches.com>
Cc:     LKML <linux-kernel@...r.kernel.org>,
        Dave Hansen <dave.hansen@...ux.intel.com>,
        Dwaipayan Ray <dwaipayanray1@...il.com>,
        LukasBulwahn <lukas.bulwahn@...il.com>,
        linux-doc@...r.kernel.org, devicetree@...r.kernel.org,
        linux-kbuild@...r.kernel.org, linux-hardening@...r.kernel.org,
        linux-riscv@...ts.infradead.org, netdev@...r.kernel.org,
        linux-csky@...r.kernel.org
Subject: Re: What is the oldest perl version being used with the kernel ?
 update oldest supported to 5.14 ?

On Fri, Aug 20, 2021 at 10:27:59AM -0700, Joe Perches wrote:
> Perl 5.8 is nearly 20 years old now.
> 
> https://en.wikipedia.org/wiki/Perl_5_version_history
> 
> checkpatch uses regexes that are incompatible with perl versions
> earlier than 5.10, but these uses are currently runtime checked
> and skipped if the perl version is too old.  This runtime checking
> skips several useful tests.
> 
> There is also some desire for tools like kernel-doc, checkpatch and
> get_maintainer to use a common library of regexes and functions:
> https://lore.kernel.org/lkml/YR2lexDd9N0sWxIW@casper.infradead.org/
> 
> It'd be useful to set the minimum perl version to something more modern.
> 
> I believe perl 5.14, now only a decade old, is a reasonable target.
> 
> Any objections or suggestions for a newer minimum version?

Not an objection per se, but some data points.

Oracle Linux 5 (released 2007, still under support) has perl 5.8.8
Oracle Linux 6 (released 2011) has perl 5.10.1
Oracle Linux 7 (released 2014) has perl 5.16.3
Oracle Linux 8 (released 2019) has perl 5.26.3

I don't know that we need to be able to build on a distro from 2007
or even from 2011.  I think it's reasonable to require updating to a
2014 distro in order to build a 2021 kernel.

For comparison, we currently require gcc-4.9 to build the kernel, and
4.9.0 was released in 2014.  So perl-5.16 wouldn't be an unreasonable
requirement, I believe.

Powered by blists - more mailing lists