lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 8 Sep 2021 08:44:40 -0300
From:   Jason Gunthorpe <>
To:     Len Baker <>
Cc:     Selvin Xavier <>,
        Naresh Kumar PBS <>,
        Doug Ledford <>,
        Kees Cook <>,,,
Subject: Re: [PATCH] RDMA/bnxt_re: Prefer kcalloc over open coded arithmetic

On Sun, Sep 05, 2021 at 10:18:12AM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> In this case this is not actually dynamic sizes: both sides of the
> multiplication are constant values. However it is best to refactor this
> anyway, just to keep the open-coded math idiom out of code.
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
> Also, remove the unnecessary initialization of the sqp_tbl variable
> since it is set a few lines later.
> [1]
> Signed-off-by: Len Baker <>
> Reviewed-by: Leon Romanovsky <>
> Acked-by: Selvin Xavier <>
> ---
>  drivers/infiniband/hw/bnxt_re/ib_verbs.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to for-rc, thanks


Powered by blists - more mailing lists