[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210912190758.GA146608@embeddedor>
Date: Sun, 12 Sep 2021 14:07:58 -0500
From: "Gustavo A. R. Silva" <gustavoars@...nel.org>
To: Len Baker <len.baker@....com>
Cc: Simon Horman <simon.horman@...igine.com>,
Jakub Kicinski <kuba@...nel.org>,
"David S. Miller" <davem@...emloft.net>,
Kees Cook <keescook@...omium.org>, oss-drivers@...igine.com,
netdev@...r.kernel.org, linux-hardening@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] nfp: Prefer struct_size over open coded arithmetic
On Sun, Sep 12, 2021 at 03:10:57PM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@....com>
Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org>
I'll take this in my -next tree. :)
Thanks, Len.
--
Gustavo
> ---
> drivers/net/ethernet/netronome/nfp/nfp_net_repr.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c b/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c
> index 3b8e675087de..369f6ae700c7 100644
> --- a/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c
> +++ b/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c
> @@ -499,8 +499,7 @@ struct nfp_reprs *nfp_reprs_alloc(unsigned int num_reprs)
> {
> struct nfp_reprs *reprs;
>
> - reprs = kzalloc(sizeof(*reprs) +
> - num_reprs * sizeof(struct net_device *), GFP_KERNEL);
> + reprs = kzalloc(struct_size(reprs, reprs, num_reprs), GFP_KERNEL);
> if (!reprs)
> return NULL;
> reprs->num_reprs = num_reprs;
> --
> 2.25.1
>
Powered by blists - more mailing lists