[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0611r11-rsq7-2n9-n834-9o31rq8qo737@onlyvoer.pbz>
Date: Sun, 12 Sep 2021 21:54:00 -0400 (EDT)
From: Nicolas Pitre <npitre@...libre.com>
To: Len Baker <len.baker@....com>
cc: Alexandre Belloni <alexandre.belloni@...tlin.com>,
Boris Brezillon <boris.brezillon@...labora.com>,
Kees Cook <keescook@...omium.org>,
linux-i3c@...ts.infradead.org, linux-hardening@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] i3c/master/mipi-i3c-hci: Prefer kcalloc over open coded
arithmetic
On Sun, 12 Sep 2021, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@....com>
Acked-by: Nicolas Pitre <npitre@...libre.com>
> ---
> drivers/i3c/master/mipi-i3c-hci/hci.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/i3c/master/mipi-i3c-hci/hci.h b/drivers/i3c/master/mipi-i3c-hci/hci.h
> index 80beb1d5be8f..f109923f6c3f 100644
> --- a/drivers/i3c/master/mipi-i3c-hci/hci.h
> +++ b/drivers/i3c/master/mipi-i3c-hci/hci.h
> @@ -98,7 +98,7 @@ struct hci_xfer {
>
> static inline struct hci_xfer *hci_alloc_xfer(unsigned int n)
> {
> - return kzalloc(sizeof(struct hci_xfer) * n, GFP_KERNEL);
> + return kcalloc(n, sizeof(struct hci_xfer), GFP_KERNEL);
> }
>
> static inline void hci_free_xfer(struct hci_xfer *xfer, unsigned int n)
> --
> 2.25.1
>
>
Powered by blists - more mailing lists