[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <32777a69-297a-f68a-d0c3-e5920035531b@embeddedor.com>
Date: Tue, 14 Sep 2021 16:49:31 -0500
From: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To: Len Baker <len.baker@....com>,
Dmitry Torokhov <dmitry.torokhov@...il.com>
Cc: Kees Cook <keescook@...omium.org>, linux-hardening@...r.kernel.org,
linux-input@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Input: omap-keypad - prefer struct_size over open coded
arithmetic
On 9/11/21 06:27, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@....com>
Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org>
Thanks
--
Gustavo
> ---
> drivers/input/keyboard/omap-keypad.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/input/keyboard/omap-keypad.c b/drivers/input/keyboard/omap-keypad.c
> index dbe836c7ff47..eb3a687796e7 100644
> --- a/drivers/input/keyboard/omap-keypad.c
> +++ b/drivers/input/keyboard/omap-keypad.c
> @@ -190,8 +190,7 @@ static int omap_kp_probe(struct platform_device *pdev)
> row_shift = get_count_order(pdata->cols);
> keycodemax = pdata->rows << row_shift;
>
> - omap_kp = kzalloc(sizeof(struct omap_kp) +
> - keycodemax * sizeof(unsigned short), GFP_KERNEL);
> + omap_kp = kzalloc(struct_size(omap_kp, keymap, keycodemax), GFP_KERNEL);
> input_dev = input_allocate_device();
> if (!omap_kp || !input_dev) {
> kfree(omap_kp);
> --
> 2.25.1
>
>
>
>
Powered by blists - more mailing lists