lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Mon, 20 Sep 2021 19:09:38 -0500 From: "Gustavo A. R. Silva" <gustavo@...eddedor.com> To: Len Baker <len.baker@....com>, David Howells <dhowells@...hat.com>, Marc Dionne <marc.dionne@...istor.com> Cc: "Gustavo A. R. Silva" <gustavoars@...nel.org>, Kees Cook <keescook@...omium.org>, linux-afs@...ts.infradead.org, linux-hardening@...r.kernel.org, linux-kernel@...r.kernel.org Subject: Re: [PATCH] afs: Prefer struct_size over open coded arithmetic On 9/19/21 04:44, Len Baker wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > So, use the struct_size() helper to do the arithmetic instead of the > argument "size + size * count" in the kzalloc() function. > > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > > Signed-off-by: Len Baker <len.baker@....com> Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org> Thanks -- Gustavo > --- > fs/afs/security.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) > > diff --git a/fs/afs/security.c b/fs/afs/security.c > index 3c7a8fc4f93f..7c6a63a30394 100644 > --- a/fs/afs/security.c > +++ b/fs/afs/security.c > @@ -219,8 +219,7 @@ void afs_cache_permit(struct afs_vnode *vnode, struct key *key, > * yet. > */ > size++; > - new = kzalloc(sizeof(struct afs_permits) + > - sizeof(struct afs_permit) * size, GFP_NOFS); > + new = kzalloc(struct_size(new, permits, size), GFP_NOFS); > if (!new) > goto out_put; > > -- > 2.25.1 >
Powered by blists - more mailing lists