lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Wed, 29 Sep 2021 19:35:07 +0200 From: Bodo Stroesser <bostroesser@...il.com> To: "Gustavo A. R. Silva" <gustavoars@...nel.org>, "Martin K. Petersen" <martin.petersen@...cle.com> Cc: linux-scsi@...r.kernel.org, target-devel@...r.kernel.org, linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org Subject: Re: [PATCH][next] scsi: target: tcmu: Use struct_size() helper in kmalloc() On 28.09.21 00:43, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version, > in order to avoid any potential type mistakes or integer overflows > that, in the worst scenario, could lead to heap overflows. > > Link: https://github.com/KSPP/linux/issues/160 > Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org> > --- > drivers/target/target_core_user.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) > > diff --git a/drivers/target/target_core_user.c b/drivers/target/target_core_user.c > index 9f552f48084c..dc220fad06fa 100644 > --- a/drivers/target/target_core_user.c > +++ b/drivers/target/target_core_user.c > @@ -1255,7 +1255,6 @@ tcmu_tmr_notify(struct se_device *se_dev, enum tcm_tmreq_table tmf, > { > int i = 0, cmd_cnt = 0; > bool unqueued = false; > - uint16_t *cmd_ids = NULL; > struct tcmu_cmd *cmd; > struct se_cmd *se_cmd; > struct tcmu_tmr *tmr; > @@ -1292,7 +1291,7 @@ tcmu_tmr_notify(struct se_device *se_dev, enum tcm_tmreq_table tmf, > pr_debug("TMR event %d on dev %s, aborted cmds %d, afflicted cmd_ids %d\n", > tcmu_tmr_type(tmf), udev->name, i, cmd_cnt); > > - tmr = kmalloc(sizeof(*tmr) + cmd_cnt * sizeof(*cmd_ids), GFP_NOIO); > + tmr = kmalloc(struct_size(tmr, tmr_cmd_ids, cmd_cnt), GFP_NOIO); > if (!tmr) > goto unlock; > > Looks good. Thank you. Reviewed-by: Bodo Stroesser <bostroesser@...il.com>
Powered by blists - more mailing lists