lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Wed, 6 Oct 2021 09:02:49 -0400 From: Steven Rostedt <rostedt@...dmis.org> To: Josh Poimboeuf <jpoimboe@...hat.com> Cc: Sami Tolvanen <samitolvanen@...gle.com>, x86@...nel.org, Kees Cook <keescook@...omium.org>, Peter Zijlstra <peterz@...radead.org>, Nathan Chancellor <nathan@...nel.org>, Nick Desaulniers <ndesaulniers@...gle.com>, Sedat Dilek <sedat.dilek@...il.com>, linux-hardening@...r.kernel.org, linux-kernel@...r.kernel.org, llvm@...ts.linux.dev Subject: Re: [PATCH v4 06/15] ftrace: Use an opaque type for functions not callable from C On Tue, 5 Oct 2021 20:29:45 -0700 Josh Poimboeuf <jpoimboe@...hat.com> wrote: Thanks for Cc'ing me, as I should have been Cc'd on the original patch. > On Thu, Sep 30, 2021 at 11:05:22AM -0700, Sami Tolvanen wrote: > > With CONFIG_CFI_CLANG, the compiler changes function references to point > > to the CFI jump table. As ftrace_call, ftrace_regs_call, and mcount_call > > are not called from C, use DECLARE_ASM_FUNC_SYMBOL to declare them. "not called from C" is a bit confusing. > > > > Signed-off-by: Sami Tolvanen <samitolvanen@...gle.com> > > --- > > include/linux/ftrace.h | 7 ++++--- > > 1 file changed, 4 insertions(+), 3 deletions(-) > > > > diff --git a/include/linux/ftrace.h b/include/linux/ftrace.h > > index 832e65f06754..67de28464aeb 100644 > > --- a/include/linux/ftrace.h > > +++ b/include/linux/ftrace.h > > @@ -578,9 +578,10 @@ extern void ftrace_replace_code(int enable); > > extern int ftrace_update_ftrace_func(ftrace_func_t func); > > extern void ftrace_caller(void); > > extern void ftrace_regs_caller(void); > > -extern void ftrace_call(void); > > -extern void ftrace_regs_call(void); > > -extern void mcount_call(void); > > + > > +DECLARE_ASM_FUNC_SYMBOL(ftrace_call); > > +DECLARE_ASM_FUNC_SYMBOL(ftrace_regs_call); > > +DECLARE_ASM_FUNC_SYMBOL(mcount_call); > > I'm thinking DECLARE_ASM_FUNC_SYMBOL needs a better name. It's not clear > from reading it why some asm symbols need the macro and others don't. > > I guess it means "an asm text symbol which isn't callable from C code > (not including alternatives)"? > > DECLARE_UNCALLED_SYMBOL() maybe? > That's even worse ;-) Because "called" is an assembler command in x86, and it is "called" from assembly (when you look at an objdump, it is most definitely "called"). Perhaps DECLARE_ASM_INTERNAL_SYMBOL() ? Or call it "DECLARE_ASM_MCOUNT_SYMBOL()" as "mcount" is the original name of what a compiler does when passed the -pg option, and that's exactly what those functions are. -- Steve
Powered by blists - more mailing lists