lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 10 Jan 2022 09:20:33 +0800
From:   xiujianfeng <xiujianfeng@...wei.com>
To:     Steven Rostedt <rostedt@...dmis.org>
CC:     <mingo@...hat.com>, <peterz@...radead.org>,
        <juri.lelli@...hat.com>, <vincent.guittot@...aro.org>,
        <dietmar.eggemann@....com>, <bsegall@...gle.com>,
        <mgorman@...e.de>, <bristot@...hat.com>, <gustavoars@...nel.org>,
        <linux-kernel@...r.kernel.org>, <linux-hardening@...r.kernel.org>
Subject: Re: [PATCH -next] sched: Use struct_size() helper in
 task_numa_group()


在 2022/1/7 22:36, Steven Rostedt 写道:
> On Fri, 7 Jan 2022 10:52:12 +0800
> Xiu Jianfeng <xiujianfeng@...wei.com> wrote:
>
>> Make use of struct_size() helper instead of an open-coded calculation.
>> There is no functional change in this patch.
>>
>> Link: https://github.com/KSPP/linux/issues/160
>> Signed-off-by: Xiu Jianfeng <xiujianfeng@...wei.com>
>> ---
>>   kernel/sched/fair.c | 7 ++-----
>>   1 file changed, 2 insertions(+), 5 deletions(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index 095b0aa378df..265e37be0c92 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
>>   	int i;
>>   
>>   	if (unlikely(!deref_curr_numa_group(p))) {
>> -		unsigned int size = sizeof(struct numa_group) +
>> -				    NR_NUMA_HINT_FAULT_STATS *
>> -				    nr_node_ids * sizeof(unsigned long);
>> -
>> -		grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
>> +		grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
>> +			      GFP_KERNEL | __GFP_NOWARN);
> I just replied yesterday. Keep the size variable. The above is too much for
> a kzalloc().

thanks, I may missed your reply mail, I'll modify and resend this patch.

>
> -- Steve
>
>
>
>
>>   		if (!grp)
>>   			return;
>>   
> .

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ