lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Mon, 10 Jan 2022 19:31:58 -0500 From: Steven Rostedt <rostedt@...dmis.org> To: Peter Zijlstra <peterz@...radead.org> Cc: Xiu Jianfeng <xiujianfeng@...wei.com>, mingo@...hat.com, juri.lelli@...hat.com, vincent.guittot@...aro.org, dietmar.eggemann@....com, bsegall@...gle.com, mgorman@...e.de, bristot@...hat.com, gustavoars@...nel.org, linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org, Linus Torvalds <torvalds@...ux-foundation.org> Subject: Re: [PATCH -next, v2] sched: Use struct_size() helper in task_numa_group() On Mon, 10 Jan 2022 23:46:15 +0100 Peter Zijlstra <peterz@...radead.org> wrote: > On Mon, Jan 10, 2022 at 09:23:54AM +0800, Xiu Jianfeng wrote: > > Make use of struct_size() helper instead of an open-coded calculation. > > There is no functional change in this patch. > > > > Link: https://github.com/KSPP/linux/issues/160 > > Signed-off-by: Xiu Jianfeng <xiujianfeng@...wei.com> > > --- > > kernel/sched/fair.c | 5 ++--- > > 1 file changed, 2 insertions(+), 3 deletions(-) > > > > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c > > index 095b0aa378df..af933a7f9e5d 100644 > > --- a/kernel/sched/fair.c > > +++ b/kernel/sched/fair.c > > @@ -2437,9 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags, > > int i; > > > > if (unlikely(!deref_curr_numa_group(p))) { > > - unsigned int size = sizeof(struct numa_group) + > > - NR_NUMA_HINT_FAULT_STATS * > > - nr_node_ids * sizeof(unsigned long); > > + unsigned int size = struct_size(grp, faults, > > + NR_NUMA_HINT_FAULT_STATS * nr_node_ids); > > Again, why?! The old code was perfectly readable, this, not so much. Because it is unsafe, and there is an effort to get rid of all open coded struct_size() code. Linus has told me to do the same with my code. https://lore.kernel.org/all/CAHk-=wiGWjxs7EVUpccZEi6esvjpHJdgHQ=vtUeJ5crL62hx9A@mail.gmail.com/ And to be honest, the new change is a lot easier to read than the original code. struct_size() lets you know the field "faults" and the number of elements. You don't need to know the size of "faults". Whereas the original code, how is that readable? From that code, how do you know what the sizeof(unsigned long) is for? -- Steve
Powered by blists - more mailing lists