lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening linux-cve-announce PHC | |
Open Source and information security mailing list archives
| ||
|
Message-ID: <202310101607.3D7ED0A@keescook> Date: Tue, 10 Oct 2023 16:09:35 -0700 From: Kees Cook <keescook@...omium.org> To: "Gustavo A. R. Silva" <gustavoars@...nel.org> Cc: Russell King <linux@...linux.org.uk>, linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org Subject: Re: [PATCH][next] atags_proc: Add __counted_by for struct buffer and use struct_size() On Tue, Oct 10, 2023 at 06:46:50AM -0600, Gustavo A. R. Silva wrote: > Prepare for the coming implementation by GCC and Clang of the __counted_by > attribute. Flexible array members annotated with __counted_by can have > their accesses bounds-checked at run-time via CONFIG_UBSAN_BOUNDS (for > array indexing) and CONFIG_FORTIFY_SOURCE (for strcpy/memcpy-family > functions). > > While there, use struct_size() helper, instead of the open-coded > version, to calculate the size for the allocation of the whole > flexible structure, including of course, the flexible-array member. > > This code was found with the help of Coccinelle, and audited and > fixed manually. > > Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org> > --- > arch/arm/kernel/atags_proc.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/arch/arm/kernel/atags_proc.c b/arch/arm/kernel/atags_proc.c > index 3ec2afe78423..cd09f8ab93e3 100644 > --- a/arch/arm/kernel/atags_proc.c > +++ b/arch/arm/kernel/atags_proc.c > @@ -7,7 +7,7 @@ > > struct buffer { > size_t size; > - char data[]; > + char data[] __counted_by(size); > }; > > static ssize_t atags_read(struct file *file, char __user *buf, > @@ -54,7 +54,7 @@ static int __init init_atags_procfs(void) > > WARN_ON(tag->hdr.tag != ATAG_NONE); > > - b = kmalloc(sizeof(*b) + size, GFP_KERNEL); > + b = kmalloc(struct_size(b, data, size), GFP_KERNEL); > if (!b) > goto nomem; > Yup, "size" is assigned before accessing "data". Reviewed-by: Kees Cook <keescook@...omium.org> -- Kees Cook
Powered by blists - more mailing lists