[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <cover.1704800524.git.christophe.leroy@csgroup.eu>
Date: Tue, 9 Jan 2024 13:14:34 +0100
From: Christophe Leroy <christophe.leroy@...roup.eu>
To: linux-hardening@...r.kernel.org,
Russell King <linux@...linux.org.uk>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>,
Michael Ellerman <mpe@...erman.id.au>,
Nicholas Piggin <npiggin@...il.com>,
"Aneesh Kumar K.V" <aneesh.kumar@...nel.org>,
"Naveen N. Rao" <naveen.n.rao@...ux.ibm.com>,
Paul Walmsley <paul.walmsley@...ive.com>,
Palmer Dabbelt <palmer@...belt.com>,
Albert Ou <aou@...s.berkeley.edu>,
Heiko Carstens <hca@...ux.ibm.com>,
Vasily Gorbik <gor@...ux.ibm.com>,
Alexander Gordeev <agordeev@...ux.ibm.com>,
Christian Borntraeger <borntraeger@...ux.ibm.com>,
Sven Schnelle <svens@...ux.ibm.com>,
Gerald Schaefer <gerald.schaefer@...ux.ibm.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>,
x86@...nel.org,
"H. Peter Anvin" <hpa@...or.com>,
Andy Lutomirski <luto@...nel.org>,
Peter Zijlstra <peterz@...radead.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Kees Cook <keescook@...omium.org>
Cc: Christophe Leroy <christophe.leroy@...roup.eu>,
linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org,
linuxppc-dev@...ts.ozlabs.org,
linux-riscv@...ts.infradead.org,
linux-s390@...r.kernel.org,
linux-mm@...ck.org,
steven.price@....com,
Phong Tran <tranmanphong@...il.com>,
mark.rutland@....com,
Greg KH <greg@...ah.com>
Subject: [PATCH 0/4] Refactor CONFIG_DEBUG_WX and check_wx_pages debugfs attribute
Refer old discussion at https://lore.kernel.org/lkml/20200422152656.GF676@willie-the-truck/T/#m802eaf33efd6f8d575939d157301b35ac0d4a64f
And https://github.com/KSPP/linux/issues/35
This series refactors CONFIG_DEBUG_WX for the 5 architectures
implementing CONFIG_GENERIC_PTDUMP
First rename stuff in ARM which uses similar names while not
implementing CONFIG_GENERIC_PTDUMP.
Then define a generic version of debug_checkwx() that calls
ptdump_check_wx() when CONFIG_DEBUG_WX is set. Call it immediately
after calling mark_rodata_ro() instead of calling it at the end of
every mark_rodata_ro().
Then implement a debugfs attribute that can be used to trigger
a W^X test at anytime and regardless of CONFIG_DEBUG_WX
Christophe Leroy (4):
arm: ptdump: Rename CONFIG_DEBUG_WX to CONFIG_ARM_DEBUG_WX
arm64, powerpc, riscv, s390, x86: Refactor CONFIG_DEBUG_WX
powerpc,s390: Define ptdump_check_wx() regardless of CONFIG_DEBUG_WX
ptdump: add check_wx_pages debugfs attribute
arch/arm/Kconfig.debug | 2 +-
arch/arm/include/asm/ptdump.h | 6 +++---
arch/arm64/include/asm/ptdump.h | 7 -------
arch/arm64/mm/mmu.c | 2 --
arch/powerpc/mm/mmu_decl.h | 6 ------
arch/powerpc/mm/pgtable_32.c | 4 ----
arch/powerpc/mm/pgtable_64.c | 3 ---
arch/powerpc/mm/ptdump/ptdump.c | 10 ++++++----
arch/riscv/include/asm/ptdump.h | 22 ----------------------
arch/riscv/mm/init.c | 3 ---
arch/riscv/mm/ptdump.c | 1 -
arch/s390/include/asm/ptdump.h | 14 --------------
arch/s390/mm/dump_pagetables.c | 8 ++------
arch/s390/mm/init.c | 2 --
arch/x86/include/asm/pgtable.h | 3 +--
arch/x86/mm/dump_pagetables.c | 3 +++
arch/x86/mm/init_32.c | 2 --
arch/x86/mm/init_64.c | 2 --
include/linux/ptdump.h | 7 +++++++
init/main.c | 2 ++
mm/ptdump.c | 19 +++++++++++++++++++
21 files changed, 44 insertions(+), 84 deletions(-)
delete mode 100644 arch/riscv/include/asm/ptdump.h
delete mode 100644 arch/s390/include/asm/ptdump.h
--
2.41.0
Powered by blists - more mailing lists