[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <77d29a54-ca71-4a2a-99ca-f2932c72e32d@embeddedor.com>
Date: Mon, 15 Jan 2024 12:24:50 -0600
From: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To: Erick Archer <erick.archer@....com>, Steven Rostedt
<rostedt@...dmis.org>, Masami Hiramatsu <mhiramat@...nel.org>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>,
Mark Rutland <mark.rutland@....com>, linux-kernel@...r.kernel.org,
linux-trace-kernel@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH v2] eventfs: Use kcalloc() instead of kzalloc()
On 1/15/24 12:16, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@....com>
Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org>
Thanks!
--
Gustavo
> ---
> Changes in v2:
> - Update the commit message to better explain the changes (Mark Rutland)
>
> Previous versions:
> v1: https://lore.kernel.org/linux-hardening/20240114105340.5746-1-erick.archer@gmx.com/
> ---
> fs/tracefs/event_inode.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/tracefs/event_inode.c b/fs/tracefs/event_inode.c
> index fdff53d5a1f8..f8196289692c 100644
> --- a/fs/tracefs/event_inode.c
> +++ b/fs/tracefs/event_inode.c
> @@ -93,7 +93,7 @@ static int eventfs_set_attr(struct mnt_idmap *idmap, struct dentry *dentry,
> /* Preallocate the children mode array if necessary */
> if (!(dentry->d_inode->i_mode & S_IFDIR)) {
> if (!ei->entry_attrs) {
> - ei->entry_attrs = kzalloc(sizeof(*ei->entry_attrs) * ei->nr_entries,
> + ei->entry_attrs = kcalloc(ei->nr_entries, sizeof(*ei->entry_attrs),
> GFP_NOFS);
> if (!ei->entry_attrs) {
> ret = -ENOMEM;
> @@ -874,7 +874,7 @@ struct eventfs_inode *eventfs_create_dir(const char *name, struct eventfs_inode
> }
>
> if (size) {
> - ei->d_children = kzalloc(sizeof(*ei->d_children) * size, GFP_KERNEL);
> + ei->d_children = kcalloc(size, sizeof(*ei->d_children), GFP_KERNEL);
> if (!ei->d_children) {
> kfree_const(ei->name);
> kfree(ei);
> @@ -941,7 +941,7 @@ struct eventfs_inode *eventfs_create_events_dir(const char *name, struct dentry
> goto fail;
>
> if (size) {
> - ei->d_children = kzalloc(sizeof(*ei->d_children) * size, GFP_KERNEL);
> + ei->d_children = kcalloc(size, sizeof(*ei->d_children), GFP_KERNEL);
> if (!ei->d_children)
> goto fail;
> }
> --
> 2.25.1
>
>
Powered by blists - more mailing lists