[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Za-NyyOP1IlQbFZg@FVFF77S0Q05N>
Date: Tue, 23 Jan 2024 09:58:35 +0000
From: Mark Rutland <mark.rutland@....com>
To: Kees Cook <keescook@...omium.org>
Cc: linux-hardening@...r.kernel.org,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>,
Kalesh Singh <kaleshsingh@...gle.com>,
Fuad Tabba <tabba@...gle.com>, Mark Brown <broonie@...nel.org>,
"Madhavan T. Venkataraman" <madvenka@...ux.microsoft.com>,
Marc Zyngier <maz@...nel.org>, linux-arm-kernel@...ts.infradead.org,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Bill Wendling <morbo@...gle.com>,
Justin Stitt <justinstitt@...gle.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 40/82] arm64: stacktrace: Refactor intentional
wrap-around test
On Mon, Jan 22, 2024 at 04:27:15PM -0800, Kees Cook wrote:
> In an effort to separate intentional arithmetic wrap-around from
> unexpected wrap-around, we need to refactor places that depend on this
> kind of math. One of the most common code patterns of this is:
>
> VAR + value < VAR
>
> Notably, this is considered "undefined behavior" for signed and pointer
> types, which the kernel works around by using the -fno-strict-overflow
> option in the build[1] (which used to just be -fwrapv). Regardless, we
> want to get the kernel source to the position where we can meaningfully
> instrument arithmetic wrap-around conditions and catch them when they
> are unexpected, regardless of whether they are signed[2], unsigned[3],
> or pointer[4] types.
>
> Refactor open-coded wrap-around addition test to use add_would_overflow().
> This paves the way to enabling the wrap-around sanitizers in the future.
>
> Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1]
> Link: https://github.com/KSPP/linux/issues/26 [2]
> Link: https://github.com/KSPP/linux/issues/27 [3]
> Link: https://github.com/KSPP/linux/issues/344 [4]
> Cc: Catalin Marinas <catalin.marinas@....com>
> Cc: Will Deacon <will@...nel.org>
> Cc: Kalesh Singh <kaleshsingh@...gle.com>
> Cc: Fuad Tabba <tabba@...gle.com>
> Cc: Mark Brown <broonie@...nel.org>
> Cc: "Madhavan T. Venkataraman" <madvenka@...ux.microsoft.com>
> Cc: Marc Zyngier <maz@...nel.org>
> Cc: Mark Rutland <mark.rutland@....com>
> Cc: linux-arm-kernel@...ts.infradead.org
> Signed-off-by: Kees Cook <keescook@...omium.org>
> ---
> arch/arm64/include/asm/stacktrace/common.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/arm64/include/asm/stacktrace/common.h b/arch/arm64/include/asm/stacktrace/common.h
> index f63dc654e545..6e0cb84961f8 100644
> --- a/arch/arm64/include/asm/stacktrace/common.h
> +++ b/arch/arm64/include/asm/stacktrace/common.h
> @@ -49,7 +49,7 @@ static inline bool stackinfo_on_stack(const struct stack_info *info,
> if (!info->low)
> return false;
>
> - if (sp < info->low || sp + size < sp || sp + size > info->high)
> + if (sp < info->low || add_would_overflow(sp, size) || sp + size > info->high)
> return false;
This looks fine to me, so FWIW:
Acked-by: Mark Rutland <mark.rutland@....com>
Mark.
>
> return true;
> --
> 2.34.1
>
Powered by blists - more mailing lists