[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87sf2mjzkc.ffs@tglx>
Date: Wed, 24 Jan 2024 20:34:11 +0100
From: Thomas Gleixner <tglx@...utronix.de>
To: Kees Cook <keescook@...omium.org>, linux-hardening@...r.kernel.org
Cc: Kees Cook <keescook@...omium.org>, John Stultz <jstultz@...gle.com>,
Stephen Boyd <sboyd@...nel.org>, "Gustavo A. R. Silva"
<gustavoars@...nel.org>, Bill Wendling <morbo@...gle.com>, Justin Stitt
<justinstitt@...gle.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 75/82] timekeeping: Refactor intentional wrap-around test
On Mon, Jan 22 2024 at 16:27, Kees Cook wrote:
> In an effort to separate intentional arithmetic wrap-around from
> unexpected wrap-around, we need to refactor places that depend on this
> kind of math. One of the most common code patterns of this is:
>
> VAR + value < VAR
>
> Notably, this is considered "undefined behavior" for signed and pointer
> types, which the kernel works around by using the -fno-strict-overflow
> option in the build[1] (which used to just be -fwrapv). Regardless, we
> want to get the kernel source to the position where we can meaningfully
> instrument arithmetic wrap-around conditions and catch them when they
> are unexpected, regardless of whether they are signed[2], unsigned[3],
> or pointer[4] types.
>
> Refactor open-coded wrap-around addition test to use add_would_overflow().
> This paves the way to enabling the wrap-around sanitizers in the future.
>
> Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1]
> Link: https://github.com/KSPP/linux/issues/26 [2]
> Link: https://github.com/KSPP/linux/issues/27 [3]
> Link: https://github.com/KSPP/linux/issues/344 [4]
> Cc: John Stultz <jstultz@...gle.com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: Stephen Boyd <sboyd@...nel.org>
> Signed-off-by: Kees Cook <keescook@...omium.org>
Reviewed-by: Thomas Gleixner <tglx@...utronix.de>
Powered by blists - more mailing lists