[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <202402091620.006E59FF9@keescook>
Date: Fri, 9 Feb 2024 16:20:11 -0800
From: Kees Cook <keescook@...omium.org>
To: Erick Archer <erick.archer@....com>
Cc: Florian Fainelli <florian.fainelli@...adcom.com>,
Thomas Gleixner <tglx@...utronix.de>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
linux-mips@...r.kernel.org, linux-kernel@...r.kernel.org,
Broadcom internal kernel review list <bcm-kernel-feedback-list@...adcom.com>,
linux-arm-kernel@...ts.infradead.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH] irqchip/irq-bcm7038-l1: Prefer struct_size over open
coded arithmetic
On Fri, Feb 09, 2024 at 07:31:28PM +0100, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the cpu variable is a pointer to "struct bcm7038_l1_cpu" and this
> structure ends in a flexible array:
>
> struct bcm7038_l1_cpu {
> void __iomem *map_base;
> u32 mask_cache[];
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> kzalloc() function.
>
> This way, the code is more readable and more safer.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162 [2]
>
> Signed-off-by: Erick Archer <erick.archer@....com>
Yeah, looks right to me.
Reviewed-by: Kees Cook <keescook@...omium.org>
--
Kees Cook
Powered by blists - more mailing lists