[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <ZdSrK6QeToAl2K2h@alpha.franken.de>
Date: Tue, 20 Feb 2024 14:37:47 +0100
From: Thomas Bogendoerfer <tsbogend@...ha.franken.de>
To: Erick Archer <erick.archer@....com>
Cc: "Gustavo A. R. Silva" <gustavoars@...nel.org>,
linux-mips@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH] MIPS: Alchemy: Use kcalloc() instead of kzalloc()
On Sat, Jan 20, 2024 at 02:34:43PM +0100, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@....com>
> ---
> arch/mips/alchemy/common/clock.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/mips/alchemy/common/clock.c b/arch/mips/alchemy/common/clock.c
> index c01be8c45271..6c8996e20a7d 100644
> --- a/arch/mips/alchemy/common/clock.c
> +++ b/arch/mips/alchemy/common/clock.c
> @@ -771,7 +771,7 @@ static int __init alchemy_clk_init_fgens(int ctype)
> }
> id.flags = CLK_SET_RATE_PARENT | CLK_GET_RATE_NOCACHE;
>
> - a = kzalloc((sizeof(*a)) * 6, GFP_KERNEL);
> + a = kcalloc(6, sizeof(*a), GFP_KERNEL);
> if (!a)
> return -ENOMEM;
>
> --
> 2.25.1
applied to mips-next.
Thomas.
--
Crap can work. Given enough thrust pigs will fly, but it's not necessarily a
good idea. [ RFC1925, 2.3 ]
Powered by blists - more mailing lists