[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <sdj7w6zhu2lzbedahqtlorxv6v55gkogr7wisbzhcxwq4mubeg@yuddsvb2dec6>
Date: Mon, 8 Apr 2024 21:45:05 +0000
From: Justin Stitt <justinstitt@...gle.com>
To: Erick Archer <erick.archer@...look.com>
Cc: Long Li <longli@...rosoft.com>, Ajay Sharma <sharmaajay@...rosoft.com>,
"K. Y. Srinivasan" <kys@...rosoft.com>, Haiyang Zhang <haiyangz@...rosoft.com>,
Wei Liu <wei.liu@...nel.org>, Dexuan Cui <decui@...rosoft.com>,
"David S. Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Kees Cook <keescook@...omium.org>, "Gustavo A. R. Silva" <gustavoars@...nel.org>,
Nathan Chancellor <nathan@...nel.org>, Nick Desaulniers <ndesaulniers@...gle.com>,
Bill Wendling <morbo@...gle.com>, Jason Gunthorpe <jgg@...pe.ca>,
Leon Romanovsky <leon@...nel.org>, Shradha Gupta <shradhagupta@...ux.microsoft.com>,
Konstantin Taranov <kotaranov@...rosoft.com>, linux-rdma@...r.kernel.org, linux-hyperv@...r.kernel.org,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org,
llvm@...ts.linux.dev
Subject: Re: [PATCH v3 3/3] net: mana: Avoid open coded arithmetic
Hi,
On Sat, Apr 06, 2024 at 04:23:37PM +0200, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1][2].
>
> As the "req" variable is a pointer to "struct mana_cfg_rx_steer_req_v2"
> and this structure ends in a flexible array:
>
> struct mana_cfg_rx_steer_req_v2 {
> [...]
> mana_handle_t indir_tab[] __counted_by(num_indir_entries);
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the calculation "size + size * count" in
> the kzalloc() function.
>
> Moreover, use the "offsetof" helper to get the indirect table offset
> instead of the "sizeof" operator and avoid the open-coded arithmetic in
> pointers using the new flex member. This new structure member also allow
> us to remove the "req_indir_tab" variable since it is no longer needed.
>
> Now, it is also possible to use the "flex_array_size" helper to compute
> the size of these trailing elements in the "memcpy" function.
>
> This way, the code is more readable and safer.
>
> This code was detected with the help of Coccinelle, and audited and
> modified manually.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/160 [2]
> Signed-off-by: Erick Archer <erick.archer@...look.com>
Reviewed-by: Justin Stitt <justinstitt@...gle.com>
> ---
> drivers/net/ethernet/microsoft/mana/mana_en.c | 14 ++++++--------
> 1 file changed, 6 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/net/ethernet/microsoft/mana/mana_en.c b/drivers/net/ethernet/microsoft/mana/mana_en.c
> index d8af5e7e15b4..f2fae659bf3b 100644
> --- a/drivers/net/ethernet/microsoft/mana/mana_en.c
> +++ b/drivers/net/ethernet/microsoft/mana/mana_en.c
> @@ -1058,11 +1058,10 @@ static int mana_cfg_vport_steering(struct mana_port_context *apc,
> struct mana_cfg_rx_steer_req_v2 *req;
> struct mana_cfg_rx_steer_resp resp = {};
> struct net_device *ndev = apc->ndev;
> - mana_handle_t *req_indir_tab;
> u32 req_buf_size;
> int err;
>
> - req_buf_size = sizeof(*req) + sizeof(mana_handle_t) * num_entries;
> + req_buf_size = struct_size(req, indir_tab, num_entries);
> req = kzalloc(req_buf_size, GFP_KERNEL);
> if (!req)
> return -ENOMEM;
> @@ -1074,7 +1073,8 @@ static int mana_cfg_vport_steering(struct mana_port_context *apc,
>
> req->vport = apc->port_handle;
> req->num_indir_entries = num_entries;
> - req->indir_tab_offset = sizeof(*req);
> + req->indir_tab_offset = offsetof(struct mana_cfg_rx_steer_req_v2,
> + indir_tab);
> req->rx_enable = rx;
> req->rss_enable = apc->rss_state;
> req->update_default_rxobj = update_default_rxobj;
> @@ -1086,11 +1086,9 @@ static int mana_cfg_vport_steering(struct mana_port_context *apc,
> if (update_key)
> memcpy(&req->hashkey, apc->hashkey, MANA_HASH_KEY_SIZE);
>
> - if (update_tab) {
> - req_indir_tab = (mana_handle_t *)(req + 1);
> - memcpy(req_indir_tab, apc->rxobj_table,
> - req->num_indir_entries * sizeof(mana_handle_t));
> - }
> + if (update_tab)
> + memcpy(req->indir_tab, apc->rxobj_table,
> + flex_array_size(req, indir_tab, req->num_indir_entries));
>
> err = mana_send_request(apc->ac, req, req_buf_size, &resp,
> sizeof(resp));
> --
> 2.25.1
>
Thanks
Justin
Powered by blists - more mailing lists