[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <41c0cb7a-6fd4-4757-8d1a-7466fa268666@embeddedor.com>
Date: Wed, 7 Aug 2024 14:43:24 -0600
From: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To: Kees Cook <keescook@...omium.org>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: Bjorn Andersson <andersson@...nel.org>,
Konrad Dybcio <konrad.dybcio@...aro.org>,
Mathieu Poirier <mathieu.poirier@...aro.org>, linux-arm-msm@...r.kernel.org,
linux-remoteproc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH][next] rpmsg: glink: Avoid -Wflex-array-member-not-at-end
warnings
>> @@ -48,7 +51,7 @@ struct glink_msg {
>> struct glink_defer_cmd {
>> struct list_head node;
>>
>> - struct glink_msg msg;
>> + struct glink_msg_hdr msg;
>> u8 data[];
>> };
>
> Instead of this change (and the container_of() uses below), I think you
> can just simply drop "data" here. I don't see anything using it except
> the struct_size()s which can all change their "data" argument to
> msg.data. e.g.:
Whaa.. I'm sorry, I totally missed this response. I think I was traveling
a lot back then.
>
> - dcmd = kzalloc(struct_size(dcmd, data, extra), GFP_ATOMIC);
> + dcmd = kzalloc(struct_size(dcmd, msg.data, extra), GFP_ATOMIC);
>
> With those changed, I think this patch becomes more readable.
Yes; I think I can change the code like this. :)
Thanks!
--
Gustavo
Powered by blists - more mailing lists