lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1e9cdcd7-b0a6-4c87-a5bb-b8e637ad8d49@amd.com>
Date: Thu, 6 Mar 2025 14:24:55 -0700
From: Alex Hung <alex.hung@....com>
To: Ethan Carter Edwards <ethan@...ancedwards.com>,
 Harry Wentland <harry.wentland@....com>, Leo Li <sunpeng.li@....com>,
 Rodrigo Siqueira <siqueira@...lia.com>,
 Alex Deucher <alexander.deucher@....com>,
 Christian König <christian.koenig@....com>,
 David Airlie <airlied@...il.com>, Simona Vetter <simona@...ll.ch>
Cc: amd-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
 linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH 0/4] drm/amd/display: move from kzalloc(size * nr, ...) to
 kcalloc(nr, size, ...)

This series LGTM too.

Reviewed-by: Alex Hung <alex.hung@....com>

On 2/27/25 16:16, Ethan Carter Edwards wrote:
> We are trying to get rid of all multiplications from allocation
> functions to prevent integer overflows. Here the multiplications are
> probably safe, but using kcalloc() is more appropriate and improves
> readability. It is also safer. This series contains a few patches
> with these fixes.
> 
> Part of the Kernel Self Protection Project efforts. Links below have
> more details.
> 
> Link: https://github.com/KSPP/linux/issues/162
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Ethan Carter Edwards <ethan@...ancedwards.com>
> ---
> Ethan Carter Edwards (4):
>        drm/amd/display: change kzalloc to kcalloc in dcn30_validate_bandwidth()
>        drm/amd/display: change kzalloc to kcalloc in dcn31_validate_bandwidth()
>        drm/amd/display: change kzalloc to kcalloc in dcn314_validate_bandwidth()
>        drm/amd/display: change kzalloc to kcalloc in dml1_validate()
> 
>   drivers/gpu/drm/amd/display/dc/resource/dcn30/dcn30_resource.c   | 3 ++-
>   drivers/gpu/drm/amd/display/dc/resource/dcn31/dcn31_resource.c   | 3 ++-
>   drivers/gpu/drm/amd/display/dc/resource/dcn314/dcn314_resource.c | 3 ++-
>   drivers/gpu/drm/amd/display/dc/resource/dcn32/dcn32_resource.c   | 3 ++-
>   4 files changed, 8 insertions(+), 4 deletions(-)
> ---
> base-commit: be5c7bbb3a64baf884481a1ba0c2f8fb2f93f7c3
> change-id: 20250227-amd-display-a8342c55a9a0
> 
> Best regards,


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ