[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <202504301201.824ADC93A@keescook>
Date: Wed, 30 Apr 2025 12:02:29 -0700
From: Kees Cook <kees@...nel.org>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Chris Mason <clm@...com>, Josef Bacik <josef@...icpanda.com>,
David Sterba <dsterba@...e.com>, linux-btrfs@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH] btrfs: compression: Adjust cb->compressed_folios
allocation type
On Sat, Apr 26, 2025 at 12:55:21AM -0600, Gustavo A. R. Silva wrote:
>
>
> On 26/04/25 00:23, Kees Cook wrote:
> > In preparation for making the kmalloc family of allocators type aware,
> > we need to make sure that the returned type from the allocation matches
> > the type of the variable being assigned. (Before, the allocator would
> > always return "void *", which can be implicitly cast to any pointer type.)
> >
> > The assigned type is "struct folio **" but the returned type will be
> > "struct page **". These are the same allocation size (pointer size), but
> > the types don't match. Adjust the allocation type to match the assignment.
> >
> > Signed-off-by: Kees Cook <kees@...nel.org>
> > ---
> > Cc: Chris Mason <clm@...com>
> > Cc: Josef Bacik <josef@...icpanda.com>
> > Cc: David Sterba <dsterba@...e.com>
> > Cc: <linux-btrfs@...r.kernel.org>
> > ---
> > fs/btrfs/compression.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/fs/btrfs/compression.c b/fs/btrfs/compression.c
> > index e7f8ee5d48a4..7f11ef559be6 100644
> > --- a/fs/btrfs/compression.c
> > +++ b/fs/btrfs/compression.c
> > @@ -606,7 +606,7 @@ void btrfs_submit_compressed_read(struct btrfs_bio *bbio)
> > free_extent_map(em);
> > cb->nr_folios = DIV_ROUND_UP(compressed_len, PAGE_SIZE);
> > - cb->compressed_folios = kcalloc(cb->nr_folios, sizeof(struct page *), GFP_NOFS);
> > + cb->compressed_folios = kcalloc(cb->nr_folios, sizeof(struct folio *), GFP_NOFS);
>
> Why not `sizeof(*cb->compressed_folios)` as in other patches? :)
I generally trying to match the coding style of each instance, though
sometimes it wasn't possible. Here, since a type is named for the
sizeof(), I followed that style.
--
Kees Cook
Powered by blists - more mailing lists