[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1154836321.29151.50.camel@localhost.localdomain>
Date: Sun, 06 Aug 2006 13:52:01 +1000
From: Rusty Russell <rusty@...tcorp.com.au>
To: Andi Kleen <ak@....de>
Cc: lkml - Kernel Mailing List <linux-kernel@...r.kernel.org>,
dmitry.torokhov@...il.com
Subject: Re: [PATCH] Turn rdmsr, rdtsc into inline functions, clarify names
On Sun, 2006-08-06 at 05:16 +0200, Andi Kleen wrote:
> > Please reconsider. This isn't about being pretty, it's about not
> > having hidden side-effects,
>
> I wouldn't call it hidden, it's well defined in the architecture.
Sorry Andi, I'm not talking about the asm, which is fine. I'm talking
about the function-style macro which alters its arguments directly.
It's very bad form.
int a, b;
rdtsc(a, b);
> > and having typechecking.
>
> The existing code will already reject any non integer and I don't
> see a particular need to be more strict than that.
Um?
u64 c;
int a,b;
rdtsc(&a, &b);
rdtscl(c);
These macros are badly named and don't check for bad usage. Sure, less
than 1% of uses is wrong at the moment, but I'm volunteering to fix them
because I think it sets a bad example and sets us up for more bugs.
I feel fairly strongly about this, but I'll drop the x86_64 changes.
Rusty.
--
Help! Save Australia from the worst of the DMCA: http://linux.org.au/law
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists