[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1157905518.26324.83.camel@localhost.localdomain>
Date: Sun, 10 Sep 2006 09:25:18 -0700
From: Dave Hansen <haveblue@...ibm.com>
To: Heiko Carstens <heiko.carstens@...ibm.com>
Cc: Roman Zippel <zippel@...ux-m68k.org>,
Andrew Morton <akpm@...l.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org,
Martin Schwidefsky <schwidefsky@...ibm.com>
Subject: Re: [patch 2/2] convert s390 page handling macros to functions v3
On Sun, 2006-09-10 at 15:08 +0200, Heiko Carstens wrote:
>
> +static inline int page_test_and_clear_dirty(struct page *page)
> +{
> + unsigned long physpage = __pa((page - mem_map) << PAGE_SHIFT);
> + int skey = page_get_storage_key(physpage);
This has nothing to do with your patch at all, but why is 'page -
mem_map' being open-coded here?
I see at least a couple of page_to_phys() definitions on some
architectures. This operation is done enough times that s390 could
probably use the same treatment.
It could at least use a page_to_pfn() instead of the 'page - mem_map'
operation, right?
-- Dave
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists