[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <45121486.3070503@pobox.com>
Date: Thu, 21 Sep 2006 00:26:46 -0400
From: Jeff Garzik <jgarzik@...ox.com>
To: Zang Roy-r61911 <tie-fei.zang@...escale.com>
CC: Roland Dreier <rdreier@...co.com>, Andrew Morton <akpm@...l.org>,
netdev <netdev@...r.kernel.org>,
linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: [patch 3/3] Add tsi108 On Chip Ethernet device driver support
Zang Roy-r61911 wrote:
> +#define TSI108_ETH_WRITE_REG(offset, val) \
> + writel(le32_to_cpu(val),data->regs + (offset))
> +
> +#define TSI108_ETH_READ_REG(offset) \
> + le32_to_cpu(readl(data->regs + (offset)))
> +
> +#define TSI108_ETH_WRITE_PHYREG(offset, val) \
> + writel(le32_to_cpu(val), data->phyregs + (offset))
> +
> +#define TSI108_ETH_READ_PHYREG(offset) \
> + le32_to_cpu(readl(data->phyregs + (offset)))
NAK:
1) writel() and readl() are defined to be little endian.
If your platform is different, then your platform should have its own
foobus_writel() and foobus_readl().
2) TSI108_ETH_WRITE_REG() is just way too long. TSI_READ(),
TSI_WRITE(), TSI_READ_PHY() and TSI_WRITE_PHY() would be far more readable.
More in next email.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists