[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1159755141.2891.434.camel@laptopd505.fenrus.org>
Date: Mon, 02 Oct 2006 04:12:21 +0200
From: Arjan van de Ven <arjan@...radead.org>
To: Matthew Wilcox <matthew@....cx>
Cc: linux-scsi@...r.kernel.org,
"Linux-Kernel," <linux-kernel@...r.kernel.org>,
"J.A. Magall??n" <jamagallon@....com>,
Alan Cox <alan@...rguk.ukuu.org.uk>,
Andrew Morton <akpm@...l.org>,
Frederik Deweerdt <deweerdt@...e.fr>,
Jeff Garzik <jeff@...zik.org>
Subject: Re: [-mm patch] aic7xxx: check irq validity (was Re: 2.6.18-mm2)
> Network drivers use their eth%d name. USB drivers use [eu]hci_hcd:usb%d.
> Others tend to use the driver name. Changing them all to be 0000:00:1d.2
> isn't really an improvement in the readability of /proc/interrupts, IMO.
hmm ok; how about allowing name to be NULL, and if it's NULL, use the
pci name?
>
> So, current proposal:
>
> int pci_request_irq(struct pci_dev *pdev, irq_handler_t handler,
> const char *name)
> {
> if (!valid_irq(pdev->irq)) {
> dev_printk(KERN_ERR, &pdev->dev, "invalid irq\n");
> return -EINVAL;
> }
>
> return request_irq(pdev->irq, handler, IRQF_SHARED, name,
> pci_get_drvdata(pdev));
> }
>
> But what about IRQF_SAMPLE_RANDOM?
that's a tough question. I'd almost suggest making such things
properties of the pdev, but sample-random is so far away from PCI
related that it makes no sense I suppose ;(
(others do I think)
One other interesting question is if this function can/should be used to
use MSI transparently (after pci_enable_msi() obviously)
--
if you want to mail me at work (you don't), use arjan (at) linux.intel.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists