[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <84144f020610122354s3f217a7fh1500f82da25f4739@mail.gmail.com>
Date: Fri, 13 Oct 2006 09:54:09 +0300
From: "Pekka Enberg" <penberg@...helsinki.fi>
To: "Andrew Morton" <akpm@...l.org>
Cc: "Josef Jeff Sipek" <jsipek@...sunysb.edu>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem
On 10/12/06, Andrew Morton <akpm@...l.org> wrote:
> Meanwhile, from a quick scan I'd say that unionfs is much, much too lightly
> commented for a review to be particularly effective. Please work on that.
Could use some basic coding style fixes too.
- Move assignments outside of if statement expression "if (err = foo_bar())"
- No C99-style comments "//"
- Use struct kmem_cache instead of the deprecated kmem_cache_t
- Don't use function-like macros as the left hand side of assignment
expression "itohi_ptr(inode) = kzalloc(size, GFP_KERNEL);". It's much
better to open-code the assignment or introduce a setter function
(e.g. inode_set_hiptr).
- Kill wrappers (e.g. unionfs_kill_block_super can be replaced with
generic_shutdown_super)
Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists