[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.64.0610281153180.2091@localhost.localdomain>
Date: Sat, 28 Oct 2006 11:56:24 -0400 (EDT)
From: "Robert P. J. Day" <rpjday@...dspring.com>
To: Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: why "probe_kernel_address()", not "probe_user_address()"?
it seems odd that the purpose of the "probe_kernel_address()" macro
is, in fact, to probe a *user* address (from linux/uaccess.h):
#define probe_kernel_address(addr, retval) \
({ \
long ret; \
\
inc_preempt_count(); \
ret = __get_user(retval, addr); \
dec_preempt_count(); \
ret; \
})
given that that routine is referenced only 5 places in the entire
source tree, wouldn't it be more meaningful to use a more appropriate
name?
pedantically yours,
rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists