[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20061107131014.535ab280.akpm@osdl.org>
Date: Tue, 7 Nov 2006 13:10:14 -0800
From: Andrew Morton <akpm@...l.org>
To: Haavard Skinnemoen <hskinnemoen@...el.com>
Cc: David Brownell <david-b@...bell.net>,
Andrew Victor <andrew@...people.com>,
Linux Kernel <linux-kernel@...r.kernel.org>
Subject: Re: [-mm patch 1/4] GPIO framework for AVR32
On Tue, 7 Nov 2006 12:27:15 +0100
Haavard Skinnemoen <hskinnemoen@...el.com> wrote:
> Add a simple GPIO framework for AVR32. This should be fairly similar
> to the AT91 GPIO API, but there are still a couple of differences:
>
> * Naming. We prefix all functions with gpio_ instead of at91_
> * request_gpio() and free_gpio() should be called to make sure
> the required pins are available, but it will still work if you
> don't.
+EXPORT_SYMBOL(request_gpio);
+EXPORT_SYMBOL(free_gpio);
+EXPORT_SYMBOL(gpio_set_value);
+EXPORT_SYMBOL(gpio_get_value);
+EXPORT_SYMBOL(gpio_set_output_enable);
+EXPORT_SYMBOL(gpio_set_pullup_enable);
I wonder about this naming choice. I'd have though that if/when the kernel
gets a generic GPIO driver or layer, these avr32-specific symbols will need
renaming.
h8300 uses h8300_free_gpio(), and there's also omap_free_gpio(). Perhaps
this patch should have added avr32_free_gpio()?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists