lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <FE74AC4E0A23124DA52B99F17F44159701DBC068@PA-EXCH03.vmware.com>
Date:	Tue, 5 Dec 2006 08:19:34 -0800
From:	"Bela Lubkin" <blubkin@...are.com>
To:	"Corey Minyard" <minyard@....org>,
	"Randy Dunlap" <randy.dunlap@...cle.com>
Cc:	"Andrew Morton" <akpm@...l.org>,
	"OpenIPMI Developers" <openipmi-developer@...ts.sourceforge.net>,
	"Linux Kernel" <linux-kernel@...r.kernel.org>,
	"Joseph Barnett" <jbarnett@...orola.com>
Subject: RE: [Openipmi-developer] [PATCH 9/12] IPMI: add pigeonpoint poweroff

Corey Minyard wrote: 
> Randy Dunlap wrote:
>> Randy Dunlap wrote:
>>> Bela Lubkin wrote:
>>>> Andrew Morton wrote:
>>>>
>>>>>> Sometime, please go through the IPMI code looking for all these
>>>>>> statically-allocated things which are initialised to 0 or NULL
>>>>>> and remove all those intialisations?  They're unneeded, they
>>>>>> increase the vmlinux image size and there are quite a number of
>>>>>> them.  Thanks.
>>>>
>>>> Randy Dunlop replied:
>>>>
>>>>> I was just about to send that patch.  Here it is,
>>>>> on top of the series-of-12.
>>>> ...
>>>>> -static int bt_debug = BT_DEBUG_OFF;
>>>>> +static int bt_debug;
>>>>
>>>> Is it wise to significantly degrade code readability to work around
>>>> a minor compiler / linker bug?
>>>
>>> Is that the only one that is a problem?
>>>
>>> I don't think it's a problem.  We *know* that static data areas
>>> are init to 0.  Everything depends on that.  If that didn't work
>>> it would all break.
>>>
>>> I could say that it's a nice coincidence that BT_DEBUG_OFF == 0,
>>> but I think that it's more than coincidence.
>>
>> It's Corey's decision.  However, while code readability is also very
>> important to me, I disagree with "significantly" above.
>
> I think the optimizations are probably important enough that this
> should be done.  Let's take Randy's patch and I will add a comment to
> BT_DEBUG_OFF that says that the value must be zero to correspond to
> the default uninitialized value.

Patch the declaration to:

  static int bt_debug;  /* 0 == BT_DEBUG_OFF */

Then any sort of grep / cscope / patch excerpts / etc. are self-
documenting.

>Bela<
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ