[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.64.0612141911240.27384@localhost.localdomain>
Date: Thu, 14 Dec 2006 19:12:59 -0500 (EST)
From: "Robert P. J. Day" <rpjday@...dspring.com>
To: Miguel Ojeda <maxextreme@...il.com>
cc: Linux kernel mailing list <linux-kernel@...r.kernel.org>
Subject: Re: lots of code could be simplified by using ARRAY_SIZE()
On Fri, 15 Dec 2006, Miguel Ojeda wrote:
> On 12/13/06, Robert P. J. Day <rpjday@...dspring.com> wrote:
> >
> > there are numerous places throughout the source tree that apparently
> > calculate the size of an array using the construct
> > "sizeof(fubar)/sizeof(fubar[0])". see for yourself:
> >
> > $ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
> >
> > but we already have, from "include/linux/kernel.h":
> >
> > #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
>
> Maybe *(x) instead of (x)[0]?
yeah, there's a bunch of that, too:
$ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\*\1\)" .
easy enough to catch using the same technique.
rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists