[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.61.0612161912390.30896@yvahk01.tjqt.qr>
Date: Sat, 16 Dec 2006 19:14:47 +0100 (MET)
From: Jan Engelhardt <jengelh@...ux01.gwdg.de>
To: "Robert P. J. Day" <rpjday@...dspring.com>
cc: Pavel Machek <pavel@....cz>,
Linux kernel mailing list <linux-kernel@...r.kernel.org>
Subject: Re: lots of code could be simplified by using ARRAY_SIZE()
On Dec 16 2006 08:09, Robert P. J. Day wrote:
>On Sat, 16 Dec 2006, Pavel Machek wrote:
>> > but we already have, from "include/linux/kernel.h":
>> >
>> > #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
>>
>> Hmmm. quite misleading name :-(. ARRAY_LEN would be better.
>
>i suspect it's *way* too late to make that kind of change, given that
>"ARRAY_SIZE" is firmly ensconced in countless places in the source
>tree and that would be a major, disruptive change.
>
>even *i* wouldn't try to promote that idea. :-)
You know, you could always make it compat for a while, but that requires
approval from Linus I suppose /* heh, heh */
I don't even know if this will compile everywhere,
but I hope you can figure out the idea...
#define ARRAY_SIZE(x) (print_warning(), sizeof(x) / sizeof(*x))
#define ARRAY_LEN(x) (sizeof(x) / sizeof(*x))
extern ...
void print_warning(void) {
printk("Don't use ARRAY_SIZE anymore, it will go away\n");
}
-`J'
--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists