[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.61.0612291106480.23545@yvahk01.tjqt.qr>
Date: Fri, 29 Dec 2006 11:13:07 +0100 (MET)
From: Jan Engelhardt <jengelh@...ux01.gwdg.de>
To: Daniel Marjamäki <daniel.marjamaki@...il.com>
cc: Arjan van de Ven <arjan@...radead.org>,
linux-kernel@...r.kernel.org
Subject: Re: Want comments regarding patch
On Dec 29 2006 07:57, Daniel Marjamäki wrote:
>
> It was my goal to improve the readability. I failed.
>
> I personally prefer to use standard functions instead of writing code.
> In my opinion using standard functions means less code that is easier to read.
Hm in that case, what about having something like
void *memset_int(void *a, int x, int n) {
asm("mov %0, %%esi;
mov %1, %%eax;
mov %2, %%ecx;
repz movsd;",
a,x,n);
}
in include/asm-i386/ and asm-x86_64/? (For x86_64, also a memset_long
that uses rsi/rax/rcx/movsq)
-`J'
--
Powered by blists - more mailing lists