[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <45CA206C.2080205@kernel.org>
Date: Wed, 07 Feb 2007 10:54:36 -0800
From: Josh Triplett <josh@...nel.org>
To: Andrew Morton <akpm@...ux-foundation.org>
CC: "Ahmed S. Darwish" <darwish.07@...il.com>,
linux-kernel@...r.kernel.org
Subject: [PATCH 1/3] rcutorture: Use ARRAY_SIZE macro when appropriate
Replace open-coded array size calculation with standard ARRAY_SIZE macro.
Signed-off-by: Ahmed S. Darwish <darwish.07@...il.com>
Signed-off-by: Josh Triplett <josh@...nel.org>
---
kernel/rcutorture.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/kernel/rcutorture.c b/kernel/rcutorture.c
index 482b11f..97c2277 100644
--- a/kernel/rcutorture.c
+++ b/kernel/rcutorture.c
@@ -899,7 +899,7 @@ rcu_torture_init(void)
/* Set up the freelist. */
INIT_LIST_HEAD(&rcu_torture_freelist);
- for (i = 0; i < sizeof(rcu_tortures) / sizeof(rcu_tortures[0]); i++) {
+ for (i = 0; i < ARRAY_SIZE(rcu_tortures); i++) {
rcu_tortures[i].rtort_mbtest = 0;
list_add_tail(&rcu_tortures[i].rtort_free,
&rcu_torture_freelist);
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists