[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20070209151848.3b7f98c1.akpm@linux-foundation.org>
Date: Fri, 9 Feb 2007 15:18:48 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Dave Hansen <hansendc@...ibm.com>
Cc: linux-kernel@...r.kernel.org, hch@...radead.org
Subject: Re: [PATCH 01/22] filesystem helpers for custom 'struct file's
On Fri, 09 Feb 2007 14:53:29 -0800
Dave Hansen <hansendc@...ibm.com> wrote:
> +/*
> + * Note: This is a crappy interface. It is here to make
> + * merging with the existing users of get_empty_filp()
> + * who have complex failure logic easier. All users
> + * of this should be moving to alloc_file().
> + */
> +int init_file(struct file *file, struct vfsmount *mnt,
> + struct dentry *dentry, mode_t mode,
> + const struct file_operations *fop)
crappy name too ;) At least two filesystems have defined their own
static-scope init_file() and so they'll explode if they somehow maange
to include file.h.
I guess we can cross that bridge when we fall off it, but sometime it might be
prudent to do s/init_file/configfs_init_file/ and ditto sysfs_init_file.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists