[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20070213082845.84212ca0.randy.dunlap@oracle.com>
Date: Tue, 13 Feb 2007 08:28:45 -0800
From: Randy Dunlap <randy.dunlap@...cle.com>
To: Muli Ben-Yehuda <muli@...ibm.com>
Cc: Joe Perches <joe@...ches.com>, linux-kernel@...r.kernel.org
Subject: Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)"
to "array_for_each(index, array)"
On Tue, 13 Feb 2007 09:37:38 +0200 Muli Ben-Yehuda wrote:
> On Mon, Feb 12, 2007 at 03:47:50PM -0800, Joe Perches wrote:
>
> > Now that most of the sizeof(array)/sizeof(array[0]) conversions have
> > been done (there are about 800 done and about another 130 left),
> > perhaps it could be useful to change the code to use a define
> > similar to the list_for_each
> >
> > #define list_for_each(pos, head) \
> > for (pos = (head)->next; prefetch(pos->next), pos != (head); \
> > pos = pos->next)
> >
> > perhaps
> >
> > #define array_for_each(index, array) \
> > for ((index) = 0; (index) < ARRAY_SIZE((array)); (index)++)
>
> Could we please stop "improving" the C language? it has served us fine
> so far.
I'm with Muli. The open-coded for loop is fine (using ARRAY_SIZE).
---
~Randy
*** Remember to use Documentation/SubmitChecklist when testing your code ***
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists